- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-18-2020 11:16 AM
I've been trying to replace my ISP router with a 1941 ISR and don't wan't to use the ISP router as a bridge.
I've successfully set up the interface and trunk and able to ping the public side from my router directly, however while all private clients are getting DHCP assigned IP's as expected and internal is fine, I'm totally stuck on getting the local machines talking...
At the moment I'm just looking to get the basic functionality sorted:
As can see, the interface is all good:
SKY_VDSL#show int ethernet 0/0/0.101
Ethernet0/0/0.101 is up, line protocol is up
Hardware is VDSL_ETHERNET, address is REDACTED (REDACTED)
Description: SKY_VDSL_Trunk
Internet address is REDACTED
MTU 1500 bytes, BW 6508 Kbit/sec, DLY 1500 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 101.
ARP type: ARPA, ARP Timeout 04:00:00
Keepalive set (10 sec)
Last clearing of "show interface" counters never
SKY_VDSL#show int ethernet 0/0/0
Ethernet0/0/0 is up, line protocol is up
Hardware is VDSL_ETHERNET, address is REDACTED (REDACTED)
Description: SKY_VDSL_Physical Interface
MTU 1500 bytes, BW 6508 Kbit/sec, DLY 1500 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:29, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/1024 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
380 packets input, 25190 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 1 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
57 packets output, 5607 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
SKY_VDSL#ping google.com
Translating "google.com"...domain server (90.207.238.97) [OK]
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.217.169.46, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms
SKY_VDSL#
My testing config is:
Current configuration : 3409 bytes
!
! Last configuration change at 16:55:13 UTC Mon May 18 2020
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SKY_VDSL
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.20
!
ip dhcp pool DHCP Address Pool
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
lease 7
!
!
!
ip cef
no ipv6 cef
!
!
flow record nbar-appmon
match ipv4 source address
match ipv4 destination address
match application name
collect interface output
collect counter bytes
collect counter packets
collect timestamp absolute first
collect timestamp absolute last
!
!
flow monitor application-mon
cache timeout active 60
record nbar-appmon
!
parameter-map type inspect global
max-incomplete low 18000
max-incomplete high 20000
nbar-classify
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1941/K9
!
!
object-group service INTERNAL_UTM_SERVICE
!
vtp mode transparent
username REDACTED privilege 15 secret 5 REDACTED
!
redundancy
!
!
!
!
!
controller VDSL 0/0/0
!
vlan 708-710,901
!
!
class-map type inspect match-any INTERNAL_DOMAIN_FILTER
match protocol msnmsgr
match protocol ymsgr
zone security LAN
zone security WAN
zone security VPN
zone security DMZ
!
!
crypto isakmp policy 1
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0/0/0
description SKY_VDSL_Physical Interface
mac-address REDACTED
no ip address
!
interface Ethernet0/0/0.101
description SKY_VDSL_Trunk
encapsulation dot1Q 101
ip dhcp client request classless-static-route
ip dhcp client client-id hex REDACTED
ip dhcp client hostname REDACTED
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
!
interface GigabitEthernet0/1/0
no ip address
!
interface GigabitEthernet0/1/1
no ip address
!
interface GigabitEthernet0/1/2
no ip address
!
interface GigabitEthernet0/1/3
no ip address
!
interface GigabitEthernet0/1/4
no ip address
!
interface GigabitEthernet0/1/5
no ip address
!
interface GigabitEthernet0/1/6
no ip address
!
interface GigabitEthernet0/1/7
no ip address
!
interface Vlan1
description Switchports 0-7
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Ethernet0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0/0/0
!
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
control-plane
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input telnet
!
scheduler allocate 20000 1000
event manager applet storePreferences
event none sync yes
action 1 file open LOG flash0:ccpexp/preferences.JSON w+
action 3 file close LOG
!
end
Any pointers would be very welcome!
Solved! Go to Solution.
- Labels:
-
Other Routing
Accepted Solutions

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-18-2020 11:29 AM
Hello,
I think you need to change:
ip nat inside source list 1 interface Ethernet0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0/0/0
to
ip nat inside source list 1 interface Ethernet0/0/0.101 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0/0/0.101 dhcp
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-18-2020 12:38 PM
Hello @DouglasBlack71617 ,
when you configure the DHCP address pool you can specify the DNS server to be passed to clients.
In your case it can be equal to the router LAN address 192.168.0.1.
This is a common setup
Hope to help
Giuseppe

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-18-2020 11:29 AM
Hello,
I think you need to change:
ip nat inside source list 1 interface Ethernet0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0/0/0
to
ip nat inside source list 1 interface Ethernet0/0/0.101 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0/0/0.101 dhcp
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-18-2020 12:14 PM
Thankyou, in hindsight it makes sense the trunk was the way to go.. seems to be mostly there, however now the client side can ping IP's externally, DNS resolution doesn't seem to be forthcoming.
On the router CLI side, both DNS names and IP's are resolved, all fine.
On the client side the DNS looks a bit off:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) Ethernet Connection (3) I218-LM
Physical Address. . . . . . . . . : 34-E6-D7-79-0D-F0
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::49c3:ac45:dc33:3faa%9(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.21(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 18 May 2020 19:50:25
Lease Expires . . . . . . . . . . : 25 May 2020 19:53:06
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 154461911
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-25-AD-EE-66-34-E6-D7-79-0D-F0
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled
If I manually set the client DNS to say 8.8.8.8 then it works fine on the client, however - far from ideal... I assume I'm missing something to pass the DNS servers over to the DHCP clients.....
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-18-2020 12:38 PM
Hello @DouglasBlack71617 ,
when you configure the DHCP address pool you can specify the DNS server to be passed to clients.
In your case it can be equal to the router LAN address 192.168.0.1.
This is a common setup
Hope to help
Giuseppe
