cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
750
Views
5
Helpful
3
Replies

Updating bandwidth to a network

Hargert42
Level 1
Level 1

I am looking to add a new connection between a Cisco 2851 and a Cisco 3745.  Currently there are two T1 connections between them for a internal 192.168.5.0 network but I would like to add a ethernet connection to give a larger pipe for when transfering large files via that network.  Can I just add the ethernet to the multigroup and shut the ethernet connection down when not needed(to limit it to t1 speeds) or is there some other way of doing this?

I have added the configs and a rough diagram below.  Currently the shutdown ethernet connections are unused and would be reconfigured. 

Thank You.

Drawing2.jpg

First device 2851

Current configuration : 6157 bytes

!

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 2851

!

boot-start-marker

boot system flash:c2800nm-adventerprisek9-mz.124-11.XW6.bin

boot system flash:c2800nm-adventerprisek9-mz.123-11.T7.bin

boot-end-marker

!

!

aaa new-model

!

aaa authentication login default group tacacs+ local

aaa authentication enable default group tacacs+ enable

aaa authorization exec default local group tacacs+

aaa authorization network default group tacacs+ local

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 0 default start-stop group tacacs+

aaa accounting commands 1 default start-stop group tacacs+

aaa accounting commands 7 default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting network default start-stop group tacacs+

aaa accounting system default start-stop group tacacs+

!

!

aaa session-id common

clock timezone mst -7

clock summer-time mdt recurring

no network-clock-participate wic 0

no network-clock-participate wic 1

!

!

!

ip cef

!

ip domain name blmntl.gov

!

multilink bundle-name authenticated

!

!

!

voice-card 0

no dspfarm

!

!

controller T1 0/0/0

framing esf

linecode b8zs

cablelength short 133

channel-group 0 timeslots 1-24

!

controller T1 0/0/1

framing esf

linecode b8zs

cablelength short 133

!

controller T1 0/1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/1/1

framing esf

linecode b8zs

!

ip ssh time-out 60

ip ssh authentication-retries 4

!

!

!

interface Loopback0

ip address 192.168.63.3 255.255.255.255

!

interface Multilink1

description To State

ip address 192.168.0.6 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ppp multilink

ppp multilink group 1

!

interface GigabitEthernet0/0

description To Infra-6506 G2/3

no ip address

ip route-cache flow

duplex auto

speed auto

!

interface GigabitEthernet0/0.801

encapsulation dot1Q 801

ip address 192.168.5.1 255.255.255.0

ip helper-address 192.168.5.27

ip helper-address 192.168.5.55

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:0

description To 3745-Edge S0/0:0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/1/0:0

description To 3745-Edge S0/2

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

ip route 0.0.0.0 0.0.0.0 192.168.0.5

ip route 192.168.5.0 255.255.255.0 192.168.62.5

ip route 192.168.63.4 255.255.255.255 192.168.62.5

!

ip flow-export version 5

ip flow-export destination 192.168.128.202 3000

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip http path flash:

ip tacacs source-interface GigabitEthernet0/0

!

logging 192.168.128.20

access-list 23 permit 10.10.10.0 0.0.0.7

!

!

!

!

!

tacacs-server host 10.121.33.55

tacacs-server host 10.121.49.55

tacacs-server directed-request

tacacs-server key 7 0010161510570A04

!

control-plane

!

!

!

!

!

alias exec c config t

!

line con 0

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password 7

transport input ssh

line vty 5 15

privilege level 15

password 7

transport input ssh

!

scheduler allocate 20000 1000

ntp clock-period 17180356

ntp server 10.121.1.1 prefer

ntp server 10.121.81.1

!

!

end

Second device 3745

sh run

Building configuration...

Current configuration : 6043 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 3745-EDGE

!

boot-start-marker

boot system flash flash:c3745-adventerprisek9-mz.123-11.T10.bin

boot-end-marker

!

card type t3 1

card type t3 2

no logging console

!

no network-clock-participate wic 0

aaa new-model

!

!

aaa group server tacacs+ tacacs1

server-private 10.121.33.55 key 7 071B245F5A051807

ip tacacs source-interface Serial1/0

!

aaa authentication login default group tacacs+ local

aaa authentication enable default group tacacs+ enable

aaa authentication ppp default group tacacs+ local

aaa authorization exec default group tacacs+ local

aaa authorization network default none

aaa accounting send stop-record authentication failure

aaa accounting update periodic 5

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 0 default start-stop group tacacs+

aaa accounting commands 1 default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting network default start-stop group tacacs+

aaa accounting connection default start-stop group tacacs+

aaa accounting system default start-stop group tacacs+

aaa session-id common

ip subnet-zero

ip cef

!

!

!

!

ip vrf ntl

rd 1:10

route-target export 1:10

route-target import 1:10

!

no ip bootp server

no ip domain lookup

ip domain name blmntl.gov

ip ssh time-out 60

ip ssh authentication-retries 4

ip ips po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

controller T1 0/0

framing esf

fdl both

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 0/1

framing esf

fdl both

linecode b8zs

channel-group 1 timeslots 1-24 speed 64

!

controller T3 1/0

!

controller T3 2/0

!

no crypto isakmp ccm

!

!

!

!

interface Loopback0

ip address 172.31.31.252 255.255.255.255

!

interface Multilink1

description To State

ip vrf forwarding ntl

ip address 192.168.0.5 255.255.255.252

ppp multilink

ppp multilink group 1

!

interface FastEthernet0/0

description To MPLS Core1

ip address 172.31.31.18 255.255.255.248

ip ospf network point-to-point

shutdown

speed 100

full-duplex

tag-switching ip

!

interface Serial0/0:0

description To 2851 S0/0/0:0

ip vrf forwarding ntl

no ip address

encapsulation ppp

no fair-queue

ppp multilink

ppp multilink group 1

!

interface FastEthernet0/1

description To ASR 1004

ip vrf forwarding ntl

ip address 10.121.210.2 255.255.255.252

shutdown

speed 100

full-duplex

!

interface Serial0/1:1

description To 2851 S0/0/1:0

ip vrf forwarding ntl

no ip address

encapsulation ppp

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/2

description To NCFO-2821

ip vrf forwarding ntl

ip address 192.168.0.9 255.255.255.252

encapsulation ppp

no fair-queue

!

interface Serial0/3

no ip address

shutdown

!

interface Serial1/0

description To NCR-Alpha S3/0

ip vrf forwarding ntl

ip address 10.121.208.2 255.255.255.252

encapsulation ppp

dsu bandwidth 44210

!

interface Serial2/0

description To NCR-Beta S3/0

ip vrf forwarding ntl

ip address 10.121.209.142 255.255.255.252

encapsulation ppp

dsu bandwidth 44210

!

router ospf 3745

router-id 172.31.31.252

log-adjacency-changes

passive-interface default

no passive-interface FastEthernet0/0

network 172.31.31.0 0.0.0.255 area 0

!

router bgp 64610

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

neighbor 10.121.208.1 remote-as 64700

neighbor 10.121.208.1 description To 3845-Alpha S3/0

neighbor 10.121.208.1 soft-reconfiguration inbound

neighbor 10.121.209.141 remote-as 64700

neighbor 10.121.209.141 description 3845-Beta S3/0

neighbor 10.121.209.141 soft-reconfiguration inbound

neighbor 172.31.31.251 remote-as 64610

neighbor 172.31.31.251 update-source Loopback0

no auto-summary

!

address-family vpnv4

neighbor 172.31.31.251 activate

neighbor 172.31.31.251 next-hop-self

neighbor 172.31.31.251 send-community extended

exit-address-family

!

address-family ipv4 vrf ntl

redistribute connected

redistribute static

neighbor 10.121.208.1 remote-as 64700

neighbor 10.121.208.1 activate

neighbor 10.121.208.1 soft-reconfiguration inbound

neighbor 10.121.209.141 remote-as 64700

neighbor 10.121.209.141 activate

neighbor 10.121.209.141 soft-reconfiguration inbound

no auto-summary

no synchronization

exit-address-family

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.31.31.251

ip route 192.168.128.0 255.255.255.0 10.121.208.1

ip route vrf abc 192.168.5.0 255.255.255.0 192.168.0.6

ip route vrf abc 192.168.6.0 255.255.255.0 192.168.0.10

ip route vrf abc 192.168.62.4 255.255.255.252 192.168.0.6

ip route vrf abc 192.168.63.3 255.255.255.255 192.168.0.6

ip route vrf abc 192.168.63.4 255.255.255.255 192.168.0.6

ip route vrf abc 192.168.63.5 255.255.255.255 192.168.0.10

!

!

no ip http server

no ip http secure-server

!!

!

!

!

control-plane

!

!

!

!

!

dial-peer cor custom

!

!

alias exec c conf t

!

line con 0

exec-timeout 0 0

password 7

logging synchronous

escape-character 61

line aux 0

line vty 0 4

exec-timeout 0 0

password 7

logging synchronous

escape-character 61

!

!

end

3745-EDGE#

3 Replies 3

vmiller
Level 7
Level 7

Multilink is a serial interface feature, so no that won't work.

Why keep the T-1's if you have ethernet ?

you could consider some traffic shaping to manage who gets what.

It is for testing field connections that have limited bandwidth so I have to keep them due to management inisisting on it. My other thought was could I put them both in the same channel-group and do it that way.  Most of the time I would just have the ethernet in shutdown and just turn it on when I need to build a machine quickly so it wont take 4 hours to upload to it.

given your configs, I would suggest just manipulating static routes to whatever IP address block you use for building your devices. Don't mess with the T-1s.

Review Cisco Networking for a $25 gift card