cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1608
Views
0
Helpful
1
Replies

Using BGP with VRF's to Emulate MPLS and Internet

kenny.kerns
Level 1
Level 1

I am setting up a lab network to emulate our production network and am using a single 2851 to emulate both my MPLS provider (only running BGP, not actually running MPLS) and our ISP that we use for our DMVPN secondary network.

Because I am using one router to function as both service providers I am running VRF's to keep the routing tables seperated. So far basic connectivity works fine, I can ping from the PE 'MPLS' VRF to the datacenter CE interface and the ISP side is working as well.

labv1.PNG

Pinging across the ISP VRF

lab-isp#ping vrf TW 66.193.134.46
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 66.193.134.46, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Pinging across the 'MPLS' VRF

lab-isp#ping vrf CL 63.156.111.46

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 63.156.111.46, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

--------------------------------------------------------------------------------------------------------------------------------------------------------

BGP is up from both the datacenter MPLS CE and the datacenter internet router.

BGP on the datacenter internet router


lab-dc1-inet#sh ip bgp summ

BGP router identifier 66.193.134.46, local AS number 33415

BGP table version is 4, main routing table version 4

1 network entries using 117 bytes of memory

1 path entries using 52 bytes of memory

2/1 BGP path/bestpath attribute entries using 248 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 417 total bytes of memory

BGP activity 2/1 prefixes, 2/1 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

66.193.134.45   4  1000      37      37        4    0    0 00:23:23        0

BGP on the datacenter MPLS CE

lab-dc1-1#sh ip bgp summ

BGP router identifier 10.152.1.250, local AS number 65000

BGP table version is 2, main routing table version 2

1 network entries using 136 bytes of memory

1 path entries using 56 bytes of memory

1/0 BGP path/bestpath attribute entries using 128 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 320 total bytes of memory

BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

63.156.111.45   4          209     156     158        2    0    0 00:24:19        0

--------------------------------------------------------------------------------------------------------------------------------------------------------

But, BGP is idle on the MPLS PE/ISP router.

BGP on the datacenter MPLS PE/ISP router

lab-isp#sh ip bgp summ

BGP router identifier 63.156.111.45, local AS number 209

BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

63.156.111.46   4        65000       0       0        1    0    0 never    Idle

66.193.134.46   4        33415       0       0        1    0    0 never    Idle

lab-isp#

--------------------------------------------------------------------------------------------------------------------------------------------------------

This is my first attempt at using VRF's in this fashion and could have easily missed something or used a config that is not nessesary.

Here is the configuration on the MPLS PE/Internet router.

ip vrf CL

rd 1:1

route-target export 1:1

route-target import 1:1

!

ip vrf TW

rd 2:2

route-target export 2:2

route-target import 2:2

!

interface GigabitEthernet0/0.1

description lab-dc1-1

encapsulation dot1Q 10

ip vrf forwarding CL

ip address 63.156.111.45 255.255.255.252

!

interface GigabitEthernet0/0.2

description lab-sea-1

encapsulation dot1Q 11

ip vrf forwarding CL

ip address 63.156.111.17 255.255.255.252

!        

interface GigabitEthernet0/1.1

description lab-dc1-inet

encapsulation dot1Q 20

ip vrf forwarding TW

ip address 66.193.134.45 255.255.255.252

router bgp 209

bgp router-id 63.156.111.45

bgp log-neighbor-changes

neighbor 63.156.111.46 remote-as 65000

neighbor 66.193.134.46 remote-as 33415

!

address-family ipv4

  neighbor 63.156.111.46 activate

  neighbor 66.193.134.46 activate

exit-address-family

!

address-family ipv4 vrf CL

  bgp router-id 63.156.111.45

  neighbor 63.156.111.46 remote-as 65000

  neighbor 63.156.111.46 activate

exit-address-family

!

address-family ipv4 vrf TW

  bgp router-id 66.193.134.45

  neighbor 66.193.134.46 remote-as 33415

  neighbor 66.193.134.46 local-as 1000

  neighbor 66.193.134.46 activate

exit-address-family

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

ip bgp-community new-format

1 Reply 1

kenny.kerns
Level 1
Level 1

I forgot to add the debug ip bgp output from the MPLS/Internet router. I have tried to add update-source to both the BGP and ipv4 family configs with no luck. I also added the multi-hop commands that are usually nessesary with update-source and still had the open active failed messages.

lab-isp#debug ip bgp

BGP debugging is on for address family: IPv4 Unicast

lab-isp#

*Nov  7 16:25:06.634: BGP: 66.193.134.46 Active open failed - update-source NULL is not available, open active delayed 8192ms (35000ms max, 60% jitter)

*Nov  7 16:25:14.826: BGP: 66.193.134.46 Active open failed - update-source NULL is not available, open active delayed 8192ms (35000ms max, 60% jitter)

*Nov  7 16:25:15.850: BGP: 63.156.111.46 Active open failed - update-source NULL is not available, open active delayed 7168ms (35000ms max, 60% jitter)

*Nov  7 16:25:23.018: BGP: 66.193.134.46 Active open failed - update-source NULL is not available, open active delayed 10240ms (35000ms max, 60% jitter)

*Nov  7 16:25:23.018: BGP: 63.156.111.46 Active open failed - update-source NULL is not available, open active delayed 7168ms (35000ms max, 60% jitter)

*Nov  7 16:25:30.186: BGP: 63.156.111.46 Active open failed - update-source NULL is not available, open active delayed 8192ms (35000ms max, 60% jitter)

*Nov  7 16:25:33.258: BGP: 66.193.134.46 Active open failed - update-source NULL is not available, open active delayed 9216ms (35000ms max, 60% jitter)un all

*Nov  7 16:25:38.378: BGP: 63.156.111.46 Active open failed - update-source NULL is not available, open active delayed 10240ms (35000ms max, 60% jitter)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: