cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1022
Views
0
Helpful
2
Replies
Highlighted
Beginner

VDSL2 on Cisco 887VA

Hi All,

I was wondering if anyway can helpme on this one. I have a customer who has put in a new VDSL2 over POTS connection. This type of connection is over PTM.

I've never setup this type of connection before on a 887VA. I have setup ADSL connections using the ATM and a dialer interface. This configuration will not work on my new service though. I've done some research on it and it appears that I need to use the interface Ethernet 0. Is this correct? Can anyway shed some light on how to configure this.

Thanks,

Eoghan

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate

Eoghan,

When you use VDSL on an 887VA you still use the RJ11 port.
However you use int E0 rather than ATM O and pppoe rather than pppoa.

You must make sure that you shut int atm0.

This config works ok in the UK on BT-Infinity
The IP address for the WAN is negotiated and the SP should give you the chap
username and password. You will also need to find out what your vlan number from

your service provider, ours is 101

Something along these lines should get you working.

!
int e0
no ip add
no shut
!
int e0.101
encap dot1q 101
pppoe enable
pppoe-client dial-pool-member 1
!
int am 0
shut
!
int dialer 1
desc *** TO MY VDSL LINE ***
mtu 1492
ip add negotiated
no ip red
nip unreach
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encap ppp
ip tcp adjust-mss 1452
dialer pooll 1
ppp authentication pap chap ms-chap callin
ppp chap hostname XXXXXX
ppp chap password XXXXXX
ppp ipcp address accept
no cdp ena
!
ip route 0.0.0.0 0.0.0.0 dialer 1
!
int vlan 1
desc *** MY SITE LAN ***
ip address 192.168.1.1 255.255.25.0
ip nat inside
ip virtual-reassembly in
no shut
!
ip access-list extended MYNAT
permit ip 192.168.1.0 0.0.0.255 any
!
ip nat inside source list MYNAT int dialer 1 overload
!

You may want to add dhcp server

ip dhcp excluded-address 192.168.1.1 192.168.1.100
!
ip dhcp pool MY-SITE-LAN
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server a.a.a.a b.b.b.b
!

I hope this helps

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

View solution in original post

2 REPLIES 2
Highlighted
Advocate

Eoghan,

When you use VDSL on an 887VA you still use the RJ11 port.
However you use int E0 rather than ATM O and pppoe rather than pppoa.

You must make sure that you shut int atm0.

This config works ok in the UK on BT-Infinity
The IP address for the WAN is negotiated and the SP should give you the chap
username and password. You will also need to find out what your vlan number from

your service provider, ours is 101

Something along these lines should get you working.

!
int e0
no ip add
no shut
!
int e0.101
encap dot1q 101
pppoe enable
pppoe-client dial-pool-member 1
!
int am 0
shut
!
int dialer 1
desc *** TO MY VDSL LINE ***
mtu 1492
ip add negotiated
no ip red
nip unreach
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encap ppp
ip tcp adjust-mss 1452
dialer pooll 1
ppp authentication pap chap ms-chap callin
ppp chap hostname XXXXXX
ppp chap password XXXXXX
ppp ipcp address accept
no cdp ena
!
ip route 0.0.0.0 0.0.0.0 dialer 1
!
int vlan 1
desc *** MY SITE LAN ***
ip address 192.168.1.1 255.255.25.0
ip nat inside
ip virtual-reassembly in
no shut
!
ip access-list extended MYNAT
permit ip 192.168.1.0 0.0.0.255 any
!
ip nat inside source list MYNAT int dialer 1 overload
!

You may want to add dhcp server

ip dhcp excluded-address 192.168.1.1 192.168.1.100
!
ip dhcp pool MY-SITE-LAN
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server a.a.a.a b.b.b.b
!

I hope this helps

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

View solution in original post

Highlighted

Thanks Alex, that answers my question perfectly.

I was thinking from online sources that this was the case but really needed the confirmation. VDSL2 is a new technology to in Ireland (marketed as "e-fibre") so this is my first configuration of it.

Thanks for your help