04-17-2014 01:43 PM - edited 03-04-2019 10:49 PM
I'm new to networking and trying to understand why our consults configured our network the way they did.
To our L3 core switch, we have one port, gig0/2, connected to an ASA via access port vlan 2 that is connected to one our of ISPs. The ASA (10.1.1.2) is the default route. Simple enough. We also have another port connected to our ISP (Optiman) switch via a trunk port. This configuration goes as follows.
Interface GigabitEthernet1/4
description **Opteman**
switchport access vlan 7
switchport trunk encapsulation dot1q
switchport trunk native vlan 7
switchport mode trunk
interface Vlan7
ip address 172.16.7.1 255.255.255.0
We also have static routes pointing to that network.
ip route 0.0.0.0 0.0.0.0 10.1.1.2
ip route 192.16.88.0 255.255.252.0 172.16.7.2
1) My questions are, since the switch port is in mode trunk, does the "switch port access vlan 7" command do nothing?
2) Since there are no port on the core configured with vlan 7 as an access port, so how does the switch know which port to route traffic to 172.16.7.2? Does it sent it out all trunk ports?
3) What purpose would the command "switch port trunk native vlan 7" serve in this configuration.
I know that the route 192.16.88.0 goes through our Optiman connection, I guess my overall issue is I don't know how. Thanks for the help.
04-17-2014 02:52 PM
Hi easternhanlai,
1) My questions are, since the switch port is in mode trunk, does the "switch port access vlan 7" command do nothing?
that is a misconfiguration.
2) Since there are no port on the core configured with vlan 7 as an access port, so how does the switch know which port to route traffic to 172.16.7.2? Does it sent it out all trunk ports?
I am not sure about this please check it
for first time it may flood and the after it will learn the port and then can use the mac address table to forward the packet.
3) What purpose would the command "switch port trunk native vlan 7" serve in this configuration.
The purpose of this command is that it change the native vlan to vlan 7 by default the native vlan is 1 native vlan is a vlan whose traffic goes untagged over trunk port
Rate the helpful posts
04-18-2014 05:19 AM
:
Interface GigabitEthernet1/4
description **Opteman**
switchport access vlan 7
switchport trunk encapsulation dot1q
switchport trunk native vlan 7
switchport mode trunk
The configuration of the interface shown is set for vlan 7, whichever takes over - the Access mode, or the trunk mode. So this is how the switch brings up the svi for vlan 7. I believe in the configuration you have, the switch will stay as an access port until the "switchport access vlan 7" is removed, but will still broadcast natively on vlan 7 as that is how the trunk is set - the native command does this - thus, it will speak.
How you have a non-internet routable scheme on the provider side is unknown, but it looks like their ip address on the other side of port g1/4 has the ip add of 172.16.7.2.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide