08-10-2012 03:58 PM - edited 03-04-2019 05:14 PM
Hello Forum,
Hopefully this is the proper channels for this type of request. I have a customer who is looking for some online documentation that shows the configurations needed to accomplish the following:
They have a L3 switch (3560-E) where all their VLANs are located and doing interVLAN routing and wish to use their ISR 871w as a default gateway to the Internet for all their VLANs configured on the switch. They want to leave the router as only as external device (to handle all traffic that comes and goes outside) and keep all other internal functions like DHCP, etc. on the 3560-E.
They are primarily looking for guidance on the NAT and IP routing configurations needed on the ISR and switch to accomplish this.
Any documents or configuration examples that you can reference will be greatly appreciated!
Thanks in advance!
Solved! Go to Solution.
08-11-2012 02:43 PM
Hello,
I do not know any document that would describe this scenario but this looks like a pretty basic configuration. The primary ideas are:
As an example:
3560:
interface FastEthernet0/24
description => Connection to 871 <=
no switchport
ip address 10.255.255.2 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 10.255.255.1
!
router rip ! Choose any protocol supported by both 3560 and 871
version 2
no auto-summary
passive-interface default
no passive-interface FastEthernet0/24
network 10.0.0.0
network ... ! Network statements for individual addresses in VLANs
871:
interface FastEthernet0/0
description => Connection to 3560-E <=
ip address 10.255.255.1 255.255.255.252
ip nat inside
no shutdown
!
interface XXX ! The WAN interface
ip nat outside
! All other necessary configuration
!
router rip ! Choose any protocol supported by both 3560 and 871
version 2
no auto-summary
passive-interface default
no passive-interface FastEthernet0/0
network 10.0.0.0
!
ip access-list standard NAT
permit N.N.N.N M.M.M.M ! Permit a VLAN for NAT
permit N.N.N.N M.M.M.M ! Permit a VLAN for NAT
...
!
ip nat inside source list NAT interface XXX overload
!
ip route 0.0.0.0 0.0.0.0 I.I.I.I ! Substitute with appropriate ISP's next hop router
Does this help at least a little? Please feel welcome to ask further!
Best regards,
Peter
08-11-2012 02:43 PM
Hello,
I do not know any document that would describe this scenario but this looks like a pretty basic configuration. The primary ideas are:
As an example:
3560:
interface FastEthernet0/24
description => Connection to 871 <=
no switchport
ip address 10.255.255.2 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 10.255.255.1
!
router rip ! Choose any protocol supported by both 3560 and 871
version 2
no auto-summary
passive-interface default
no passive-interface FastEthernet0/24
network 10.0.0.0
network ... ! Network statements for individual addresses in VLANs
871:
interface FastEthernet0/0
description => Connection to 3560-E <=
ip address 10.255.255.1 255.255.255.252
ip nat inside
no shutdown
!
interface XXX ! The WAN interface
ip nat outside
! All other necessary configuration
!
router rip ! Choose any protocol supported by both 3560 and 871
version 2
no auto-summary
passive-interface default
no passive-interface FastEthernet0/0
network 10.0.0.0
!
ip access-list standard NAT
permit N.N.N.N M.M.M.M ! Permit a VLAN for NAT
permit N.N.N.N M.M.M.M ! Permit a VLAN for NAT
...
!
ip nat inside source list NAT interface XXX overload
!
ip route 0.0.0.0 0.0.0.0 I.I.I.I ! Substitute with appropriate ISP's next hop router
Does this help at least a little? Please feel welcome to ask further!
Best regards,
Peter
08-11-2012 06:51 PM
Peter,
Thanks for the response!
I will pass this information along to my customer.
Thanks again!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide