cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
491
Views
0
Helpful
8
Replies

What is CPE Router configuration doing?

eagleeye
Level 1
Level 1

Can someone explain what this configuration is doing, at a high-level, I am just trying to understand what is going on here?  The route-map statements 20, 30, and 40 really don't do anything, correct?

eagleeye_0-1710635550725.png

 

CPE-1 Configuration
router bgp 2152
neighbor casc-dc peer-group
neighbor casc-dc remote-as 2152
neighbor casc-dc update-source Loopback0
neighbor 1.2.3.4 peer-group casc-dc
neighbor 1.2.3.4 password CISCO
!
address-family ipv4
bgp dampening
redistribute static route-map static-to-bgp
neighbor casc-dc send-community
neighbor 1.2.3.4 activate
exit-address-family
!
!
ip prefix-list cust-no-export seq 10 permit 2.3.4.5/24 le 32
ip prefix-list cust-no-export seq 400 deny 0.0.0.0/0 le 32
!
ip prefix-list cust-announce seq 400 deny 0.0.0.0/0 le 32
!
ip prefix-list cust-backup-announce seq 400 deny 0.0.0.0/0 le 32
!
ip prefix-list cust-backup-no-export seq 400 deny 0.0.0.0/0 le 32
route-map static-to-bgp permit 10
match ip address prefix-list cust-no-export
set ip next-hop 1.1.1.1
set origin igp
set as-path tag
set community 2152:65439 2152:65502 2152:65535
!
route-map static-to-bgp permit 20
match ip address prefix-list cust-announce
set ip next-hop 1.1.1.1
set origin igp
set as-path tag
set community 2152:65298 2152:65436 2152:65438 2152:65439 2152:65498 2152:65502 2153:65418 2153:65436 2153:65438
!
route-map static-to-bgp permit 30
match ip address prefix-list cust-backup-announce
set ip next-hop 1.1.1.1
set local-preference 98
set weight 0
set origin igp
set as-path tag
set community 2152:65298 2152:65436 2152:65438 2152:65439 2152:65498 2152:65502 2153:65418 2153:65436 2153:65438
!
route-map static-to-bgp permit 40
match ip address prefix-list cust-backup-no-export
set ip next-hop 1.1.1.1
set local-preference 98
set weight 0
set origin igp
set as-path tag
set community 2152:65439 2152:65502 2152:65535
!
!
Ip route 1.2.3.4 255.255.255.255 GigabitEthernet0/0/0
ip route 2.3.4.5 255.255.255.0 GigabitEthernet0/0/1 tag 100

1 Accepted Solution

Accepted Solutions

chrihussey
VIP Alumni
VIP Alumni

#1 - I've never used that particular command so unless I've actually done it, I'm hesitant to answer.  But from what I've read that is correct. It will show the AS path as being from AS 100. Just the single value though, if you wanted to add more AS's then "set as-path prepend" would be the command. Others more familiar may have a different understanding.

#2 - It represents all subnets in the range of 2.3.4.5/24 through /32. That would include /25, /26, /27..../32. So if there were /32 host routes they would be included too.

View solution in original post

8 Replies 8

chrihussey
VIP Alumni
VIP Alumni

Hello, 

That's the way it looks to me...the "deny 0.0.0.0/0 le 32" denies everything.

BTW - the two statics are technically incorrect in that they need to point to an IP address and not to the GigabitEthernet interfaces. 

Hello
FYI-
A match can be found pertaining to the below:

ip route 2.3.4.5 255.255.255.0 GigabitEthernet0/0/1 tag 100

ip prefix-list cust-no-export seq 10 permit 2.3.4.5/24 le 32
ip prefix-list cust-no-export seq 400 deny 0.0.0.0/0 le 32

route-map static-to-bgp permit 10

match ip address prefix-list cust-no-export

 

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

1. So, for this example, with the tag set for route 2.3.4.5/24

ip route 2.3.4.5 255.255.255.0 GigabitEthernet0/0/1 tag 100

the "set as-path tag" in this route map will convert the tag of this route into an autonomous system path of 100, thereby prepending to the existing AS path?  So, the bottom line, for this example, is it a case of traffic engineering to lengthen the AS path between the CASc backbone and the subnet 2.3.4.5/24 at CUST-1?

2.  The prefix-list, ip prefix-list cust-no-export seq 10 permit 2.3.4.5/24 le 32

Does 2.3.4.5/24 le 32  represent just a single host 2.3.4.5/24 or does it represent all 254 hosts 2.3.4.1 to 2.3.4.254 with subnet mask 255.255.255.0?

covert the IGP tag to AS-PATH is used mostly for prevent loop
you mention TE can you more elaborate

MHM 

chrihussey
VIP Alumni
VIP Alumni

#1 - I've never used that particular command so unless I've actually done it, I'm hesitant to answer.  But from what I've read that is correct. It will show the AS path as being from AS 100. Just the single value though, if you wanted to add more AS's then "set as-path prepend" would be the command. Others more familiar may have a different understanding.

#2 - It represents all subnets in the range of 2.3.4.5/24 through /32. That would include /25, /26, /27..../32. So if there were /32 host routes they would be included too.

Got it.  Thank you.

Hello


@eagleeye wrote:

1. So, for this example, with the tag set for route 2.3.4.5/24

ip route 2.3.4.5 255.255.255.0 GigabitEthernet0/0/1 tag 100

the "set as-path tag" in this route map will convert the tag of this route into an autonomous system path of 100, thereby prepending to the existing AS path?  So, the bottom line, for this example, is it a case of traffic engineering to lengthen the AS path between the CASc backbone and the subnet 2.3.4.5/24 at CUST-1?

If you only have a single ebgp peering why do you need to advertise your redistributed statics will as-path prepending?



@eagleeye wrote:
2.  The prefix-list, ip prefix-list cust-no-export seq 10 permit 2.3.4.5/24 le 32

Does 2.3.4.5/24 le 32  represent just a single host 2.3.4.5/24 or does it represent all 254 hosts 2.3.4.1 to 2.3.4.254 with subnet mask 255.255.255.0?



This PF encompasses 2.3.4.0/24 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

This was an after-class study assignment by my teacher after a tutorial on route-maps. I think I understand it now.  Thanks.

Review Cisco Networking products for a $25 gift card