cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
293
Views
3
Helpful
4
Replies

WIC port Doesn't Accept IP interface assigning

Ammar
Level 1
Level 1

I'm trying a new Fa Port to my router using HWIC-4ESW, for Example the new port is Fa0/1/0, whenever i try to assign in ip to that interface using the command =>
```
Router(config)# interface fa0/1/0
Router(config-if)# ip address 50.0.0.1 255.0.0.0
```
i get this error message :

```
% Invalid input detected at '^' marker.
```

1 Accepted Solution

Accepted Solutions

M02@rt37
VIP
VIP

Hello @Ammar  

HWIC-4ESW is strictly a L2 module, meaning it only supports SVI-based L3 connectivity.

So, if the goal is to assign an IP address directly to an interface, the HWIC-4ESW won't support "no switchport" command.

Since HWIC-4ESW ports act as switchports, you must create a VLAN interface and assign the ip address like that:

Router(config)# interface Vlan1
Router(config-if)# ip address 50.0.0.1 255.0.0.0
Router(config-if)# no shutdown

Router(config)# interface fa0/1/0
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 1

-- on the other side, other module liek HWIC-2FE are routed interfaces.

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

View solution in original post

4 Replies 4

marce1000
Hall of Fame
Hall of Fame

 

 - You may need the "no switchport" command first ,which changes the port from being a Layer 2 interface to a layer 3 interface.

 M.



-- Each morning when I wake up and look into the mirror I always say ' Why am I so brilliant ? '
    When the mirror will then always repond to me with ' The only thing that exceeds your brilliance is your beauty! '

M02@rt37
VIP
VIP

Hello @Ammar  

HWIC-4ESW is strictly a L2 module, meaning it only supports SVI-based L3 connectivity.

So, if the goal is to assign an IP address directly to an interface, the HWIC-4ESW won't support "no switchport" command.

Since HWIC-4ESW ports act as switchports, you must create a VLAN interface and assign the ip address like that:

Router(config)# interface Vlan1
Router(config-if)# ip address 50.0.0.1 255.0.0.0
Router(config-if)# no shutdown

Router(config)# interface fa0/1/0
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 1

-- on the other side, other module liek HWIC-2FE are routed interfaces.

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Thanks a lot my Dear, this was so Helpful . i Found that router 2811suppoerts 2FE2W which i can assign an ip to it's Interfaces , But what Router Model in Packet Tracer Supports HWIC-2FE Because i didn't find it.


@Ammar  wrote:

Thanks a lot my Dear, this was so Helpful . i Found that router 2811suppoerts 2FE2W which i can assign an ip to it's Interfaces , But what Router Model in Packet Tracer Supports HWIC-2FE Because i didn't find it.


Might not be there at all, as PT doesn't simulate all hardware, and the hardware it does simulate, may be missing features.