Showing results for 
Search instead for 
Did you mean: 
Level 1
Level 1

Introduction: This document describes step by step approach on how to take care of  IDM or ASDM Java memory Heap issue.


1.      IPS or ASA

2.       IDM or ASDM Software


Try 1 of the following procedures----

1.      - Right click "Cisco ASDM Launcher" > Properties

2.      - Click "Find Target"

3.      - opens ASDM target directory

4.      - disabled "asdm-launcher.config" file from read-only

5.      - edit the file, changing the 2 params for Xms and Xmx to 256 & 512

6.      - save, close and revert to read-only

7.      - restart ASDM and my IPS section works


1.      Right click "Cisco ASDM Launcher" > Properties

2.      Click "open file location"

3.      opens ASDM target directory

4.      -copy file  "asdm-launcher.config" to desktop and disabled "asdm-launcher.config" file from read-only

5.      delete "asdm-launcher.config" file in ASDM folder

6.      edit the file on desktop, changing vmparam to = vmparam -Xmx300m

7.      copy file from desktop "asdm-launcher.config" into ASDM folder

8.      save, close and revert file to read-only

9.      restart ASDM and IPS section works

This document was created from following discussion-----

Hope this is helpful.

Community Member

This change is "not supported and will require this device to be re-imaged to guarantee proper operation" but you can login and change these parameters with the service account to fix IDM on an IPS 4200 series to work with java 1.6


<j2se version="1.4+" initial-heap-size="256m" max-heap-size="512m"/>

Level 1
Level 1

This worked perfectly for me and the step-by-step was spot on, thanks!

Tee Chin Poh
Level 1
Level 1

i can't find asdm-laucher.config in c:\program files\cisco systems\ASDM\ . i have set java in control panel to -Xmx512m but still cannot work. i currently can access asdm but cannot access idm5.0 via web. it prompt up heap size less than 256. any way can try?

Level 1
Level 1

For me what it worked was:

1. Right-click on the IDM icon -> Properties

2. Check the Target and go the the mentioned directory (in my case the path was:

"C:\Documents and Settings\HOST2\Application Data\Sun\Java\Deployment\cache\6.0\55\736982f7-26e9de5d", so I had to go to the directory "C:\Documents and Settings\HOST2\Application Data\Sun\Java\Deployment\cache\6.0\55\" and find the file '736982f7-26e9de5d' - check what is in your case.

3. In the directory will be 2 files with the same name, but the one will have .idx extension. Edit the file that has no extension (736982f7-26e9de5d in my case). Change the line

<j2se version="1.4+" initial-heap-size="64m" max-heap-size="256m"/>


<j2se version="1.4+" initial-heap-size="265m" max-heap-size="512m"/>

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: