cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

698
Views
0
Helpful
1
Replies
changcheng Guo
Beginner

How to config HSRP over A-VPLS

Hi,

There are two datacenters, connected with a pair of 10 gig dark fiber connections. There are a handful of VLANs riding across the DCI links in a stretched L2 configuration for the purposes of vMotion and a handful of proprietary "stretched-cluster" apps.We have configured A-VPLS over GRE on the Core Switch,but HSRP is not working now ,please help me to resove it ,many thanks.

CAT6509E-VSS:

!
mpls label protocol ldp

!

!
pseudowire-class cl1
 encapsulation mpls
 load-balance flow
 flow-label enable
!

................

interface Vlan125
 description Used for DCI_VMOTION
 ip address 192.168.125.252 255.255.255.0
 standby 125 ip 192.168.125.254
 standby 125 preempt
!

interface Vlan401
 description connect_to_ls_6807
 ip address 172.16.0.1 255.255.255.252
 ip ospf network point-to-point
 ip ospf cost 10
!

!
interface Tunnel0
 ip unnumbered Loopback0
 no ip redirects
 mpls ip
 tunnel source 172.16.0.1
 tunnel destination 172.16.0.2
!

............

interface Virtual-Ethernet1
 switchport
 switchport mode trunk
 switchport trunk allowed vlan 125
 transport vpls mesh
  neighbor 10.2.255.1 pw-class cl1
!
router ospf 100
 router-id 10.0.255.1
 redistribute connected subnets
 redistribute static subnets
 network 172.16.0.1 0.0.0.0 area 0

!

CAT6807XL-VSS:

!
mpls label protocol ldp

!

!
pseudowire-class cl1
 encapsulation mpls
 load-balance flow
 flow-label enable
!

................

interface Vlan125
 description Used for DCI_VMOTION
 ip address 192.168.125.253 255.255.255.0
 standby 100 ip 192.168.125.254
 standby 100 preempt
!

interface Vlan401
 description connect_to_ls_6509
 ip address 172.16.0.2 255.255.255.252
 ip ospf network point-to-point
 ip ospf cost 10
!

!
interface Tunnel0
 ip unnumbered Loopback0
 no ip redirects
 mpls ip
 tunnel source 172.16.0.2
 tunnel destination 172.16.0.1
!

............

interface Virtual-Ethernet1
 switchport
 switchport mode trunk
 switchport trunk allowed vlan 125
 transport vpls mesh
  neighbor 10.0.255.1 pw-class cl1
!
router ospf 100
 router-id 10.2.255.1
 redistribute connected subnets
 redistribute static subnets
 network 172.16.0.2 0.0.0.0 area 0

!

1 REPLY 1
joselopez
Beginner

Hello ,

 

 

In the vlan 125 , the standby group is not the same.

in the CAT6509E-VSS: the standby group is 125 and in the CAT6807XL-VSS , the group is 100.

 

Have a nice W-K,

 

José