cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4299
Views
0
Helpful
4
Replies
Highlighted

Nexus Disabling dynamic MAC learning for control plane protection

Hi Community,

Please let me know if the default behavior of 'disabling dynamic MAC learning' can be turned off on the Nexus switches?

I  understand that the Nexus have this behavior to protect the control plane when a loop is detected. But my question is, can it be turned off?

Thanks,

 

Fede.

4 REPLIES 4
Highlighted
Cisco Employee

This example shows how to disable the MAC address learning mode:
N7K# configure terminal
N7K (config)# no mac address-table fabricpath remote-learning



This example shows how to disable the MAC learning mode on the specified module:
switch# configure terminal
switch(config)# no hardware fabricpath mac-learning module 4

NOTE:- 

Disabling dynamic MAC address learning on a Nexus switch will cause the device to flood
the packets across the entire broadcast domain which at the end can cause network outages.

HTH

Regards

Inayath

***Please do not forget to rate the post if this is helpfull*****

Highlighted

Thank you but I don't want to disable MAC learning!

The Nexus switches disable dynamic MAC learning for a period of 120-240 seconds when finding a loop. My question is if there's a command to disable this behavior.

 

Federico.

 

Highlighted

I am sorry that this cannot be achieved.


The switch disables MAC address learning to protect its control plane.
This is implemented on all VLANs even if the loop occurred on only one VLAN.

In Release 5.2(1)N1(1) and later, this behavior was changed to disable learning on only the VLAN where the loop occurred.

An interesting command which helps for troubleshooting L2 loops in the future is the ‘mac-address-table notification’ command
The addition of these commands ensures that the syslog for FWM detect displays when there is a MAC address move.

HTH

Regards

Inayath

**Please rate all usefull post**

Highlighted

I have same issue, my whole network is on fire.. we have following configuration on all my server racks 

 

My all servers in bond (mode=1) configuration but they are doing round-robin so they are sending TOR1 and TOR2 so my vPC switches showing mac moving notification and blocking mac learning.. Do you this this is bad design 

 

I have mentioned in diagram active-backup but its round-robin.


Screen Shot 2018-07-04 at 11.24.06 PM.png

Content for Community-Ad
This widget could not be displayed.