Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Advanced DHCP Configuration

Dear people,

I was glad to see that in some tftpboot issues have been adressed. However I run into a problem.

I setup the Advanced DHCP with the tftp server ip (also tried hostname btw), configured the

DHCP Client Device vs. Configuration File Mapping Table. When I try to tftp boot any device, the devices search for the boot file not on the tftp server (, but on the RV180 itself ( I find this very confusing. Could it be that tftp function 66 isn't working as it should be, or could it be something in my local configuration? Are there any limitations I should know about?



It sounds like there's a tftp server on the rv180 that's causing the problem.  I'd try this:

- Setup another router of any sort that can take care of being the default gateway.  The cheaper and more consumer it is, the better.

- Try your tftp again and see if it hits the server.  If so, then the rv180 has a hidden tftp server that needs to be turned off.

Huntsville's Premiere Car and Bike e-magazine:

Huntsville's Premiere Car and Bike e-magazine:



Tried same config on RV180 with latest firmware ( and still offering the RV IP as the TFTP server IP.

Setting MAC and filename on the advanced DCHP tab:

- Phone get as TFTP server the RV180 LAN IP

- Phone get filename correctly

- RV180 get the file from the real TFTP server!! (PBX)

But phones doesn't work correctly (need more than 1 config file form PBX).


Any other idea or equivalent router suggestion that manage "correctly" DHCP option 67/150?





Hi Samir,

Thanx for the reply.

I used to have a wrt54g as the default gateway in my network, tftpbooting just went fine, all my clients were able to connect to the tftpserver and load the designated files. I swapped the wrt54g with the rv180 (gigabit etc) assuming the information in the datasheet was based on real functionality. Unfortunately tftp on the rv180 was a diisapointment from the start. The first two firmware releases only accepted tabeling with .cfg files. Now, in release nr 3, the webui allows the mapping of other than .cfg files. Gladly I can map .0 and .bin files now. Clients doing tft-booting receive an ipadress and wait for (rv180) to hand them the right files, ofcourse this never happends. I wonder what firmeware version will hold the fix to this problem. it could be that the rv180 has a hidden tftp-server, or maybe tftp-function 66 is just not working. Tftp-function 150 is also a next-server funtion, it is proprietary from Cisco itself. My clients and tftp-server are not familiar with this function, maybe the rv180 has trouble choosing 66 or 150?


Hi Mario,

Thanx for the reply.

It is confusing, some web tutorials (on concerning the rv180 are mentioning that the rv180 should be able to grab its own startup config from a tftp-server. I never encountered that function though. As far as I know the rv180 should be able to tell tftp-clients what the tftp-server adress is (function 66/150) and it should be able to tell the client what file they have to load (function 67).

Attached clients do get an ip, but never find the right tftp-server. When I do not map the client in the rv180, they do not get an ip. Something is going wright, it is mainly going wrong though.

Samir Darji

Depending on how critical your tftp functionality is, I think you'll have to weight the options of just getting a new wrt54g (or equivalent with gigabit).

I've noticed that while consumer-grade equipment usually has drawbacks, sometimes its simplicity really helps.  I used an old Linksys 'Network Anywhere' $20 router today to run a host of vpn test between a Netgear FVS114 and two RV016s.  Even though it was slow on the Internet side, it served out IPs and routed remarkably well.  I think I would have had issues had I used a 'business grade' piece of equipment for the core in my test.

Huntsville's Premiere Car and Bike e-magazine:

Huntsville's Premiere Car and Bike e-magazine:

Hi Samir,

Thanx for your reply.

Initially I indeed intended to buy a gigbit version of the wrt54g, unfortunately I never found one, I don't think they're availeble. This rv180 seemed to be a nice solution because it had all the functionality of the wrt54, allthough acording to the datasheet...

I spoke to a Cisco network enigeer, she was also quite puzzled. Wireshark pointed out clearly that the rv180 does not relay the tftp request to the server, so option 66 is not working in my situation. I'm trying to pxe-boot some clients, however the rv180 doesn't seem to like .0 files, the engineer suggested that probably the rv180 only likes .cfg. If this is the case (and I suspect that to be true because previous firmwareversions didn't even allow the entry of non-.cfg files), it would be a pitty. And yes in that case the only sollution is to build an independent network for the clients only, that would be to bad and very inefficient.