Showing results for 
Search instead for 
Did you mean: 


  • New Firmware Available for the RV340 Series Router Family! posted Apr 30, 2019
This includes the RV340, RV340W, RV345, and RV345P. To learn more and get the latest Firmware version click here

  • Important Update: Cisco RV340 Series and Cisco AnyConnect Secure Mobility Client posted Nov 10, 2018
The RV340 Series supports Remote Tunnel Termination of the best-selling and easy to use Cisco AnyConnect Secure Mobility Client... read more

RV042 QuickVPN loops while verifying network

Sorry, this is an age old story but I have to touch on it again.

I used to have the problem where QuickVPN keeps on trying to verify the network because the RV042 cannot get the final ping to the client.

I then bought a RV042 HW version 3 on the VPN side and I installed RV042's at the clients as well.

This may look like overkill but believe me, it gives peace of mind, it made things a whole lot better, everybody happy.

I am going to set up tunnels but for the time being the clients use QuickVPN.

The above setup is all good if people access the vpn from the same source.

I now have a problem where one of our people is in Vietnam and she cannot access the vpn due to the "verifying network" loop.

Looking at the log everything looks great, I compared a successful connect with an unsuccessful one and the logs are identical.

The only difference is that the final ping is blocked (recorded in the QuickVPN log on the client side).

The client uses W7 with firewall on.

No need to repeat suggestions, such as turing printer sharing off, I have been through all that.

Now to the question: isn't this simply caused by the ISP in Vietnam blocking pings ?

And, if so, is there any way to get around this ?


RV042 QuickVPN loops while verifying network

I just had this probem again from another ISP.

Everything works except the final ping.

Why not ignore the final ping ?

Anybody ?


RV042 QuickVPN loops while verifying network

Hello Mr. Vermejj,

Remember that when you use a VPN client on  Windows 7. You would need to turn on the firewall and create 2 rules.

First go to Advance Settings.

Inbound rules → New rule → Custom rule =

All programs → Protocol set as icmp V4


Any IP → allow connection and leave the 3 next options checked.

Diego Rodriguez

Cisco network engineer

Thank you

*If this answer was satisfactory for you, please mark the question as Answered.*