cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

12144
Views
0
Helpful
7
Replies
johnandersen2012
Beginner

RV042 Setting up PPTP VPN

Okay, I took the helpful advise here and have reworked my network to use a RV042 router.  It is connected to my cable modem and working well.  I may add a DSL connection later in the month as a backup.  All I really want to do now is setup my PPTP VPN connection.  I have not been able to find a guide so I will assume it isn't that bad.   I set up 2 accounts in the VPN-PPTP Server screen.  Built my connection on my android phone and voila nothing works.  So I tried to disable the "Block WAN requests".  I tried port forwarding the VPN to 192.168.1.1 (address of the router) and no luck.   AT this point I am stuck.   I know my infrastructure is right because from outside the network I can

https://my.dyddns.com:443 and see my router configuration.  Now if I could just get a simple PPTP connection I would be a happy guy.

Thanks in advance for your help.

7 REPLIES 7
Te-Kai Liu
Rising star

This thread discussed how to use PPTP Client on iOS to connect to RV042. It's not Andriod specific though.

https://supportforums.cisco.com/message/3496500#3496500

Android doesn't seem to be my problem.  I can't get at it from a laptop on the outside either.  But I can use remote management to get at the router which means the connection is good.  Must be something I asm missing in the PPTP setup.  I am hoping someone can tell me what I might have missed or can connect to the remote management and have a look to see if they can connect and then build a pptp connection.

Thanks,

John

Hi John, you are unable to connect with PPTP or you can connect but can't access anything? If you're able to connect but can't access anything, it is because Firewalls don't accept inbound connections from anything other than their own subnet. It means you need to tell the firewall to accept request from the PPTP subnet or disable the firewalls on the resources (computers, servers, etc.).

If you're not able to connect with PPTP at all, I'd check how you set up the PPTP connection for the connecting computer. If that is fine, then I'd double check the upstream connection (connect directly to your modem) and ensure your computer receives the public IP and not a private NAT IP.

As far as the router set up, there isn't really anyhing to it... You enable the server, create a user name/password, add to list, save the page. That's all the router config.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

I am gettin gthe feeling that this is just not meant to be.  Let me go through what I know so far.  I am trying to set up a simple PPTP server. I have the RV042 configured as suggested.  I know my connection to the router is good, as can be evidenced by going to https://boa****.homeip.net:443

I have tried to build pptp connection with windows, android, and apple.  No success.   I have turned off the firewall on the router, although I don't think that is the problem.  I haven't even actually made a connection.

I am sooooo frustrated I went and purchased a second router just to make sure this one wasn't faulty.  Same issue.

Hi John, the problem is, we don't know anything about your location that you're trying to connect to. Because you can make a connection to port 443 is not the same as making a connection on port 1723. It also does not indicate what your upstream devices are or how they handle traffic.

Assuming the router has PPTP enabled and you set up a user/password and there is not an input error for the credential, then it is one of two things. Either you are not correctly making the PPTP adapter setting or your upstream device is interfereing. There is almost no other cause for lack of connecting.

So, the first thing you should do is connect your computer directly to your modem and verify the IP you receive. Ensure it is not private / NAT and your modem is not a router device.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Thanks Tom,

We are getting somewhere.  I tried to connect the vpn from within my network. It worked, validated my user id and password and gave me a new ip in the assigned range.  So inside my 192.168.1.1 local network I used a laptop (ip 192.168.1.44) and made a vpn connection that gave me a new vpn address of 192.162.1.201 (the expected range). I know there is no reason to do this but i did verify what a valid connection would look like. 

So to answer you question, I have a cable modem connected to the rv042. It is a motorola surfboard and I don't believe it acts as router.  I'm not sure why this is so difficult.  I was able to do this with a netgear router running ddwrt about 6 months ago.  That router expired (cheap hardware) and I just figured this would work the same.

Please keep asking and I will tell you what i know.  Thanks for being so patient.

Send me a message with your WAN IP address and a user name/password. I will attempt to connect from my location. Your PPTP subnet range should be outside of your normal LAN range as well. Although you can use the same subnet as the PPTP it can make some weird issues.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/