cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

838
Views
0
Helpful
3
Replies
vjmendoza
Enthusiast

FCIP tunnels configuration and validation

Hello,

I have configured FCIP tunnels before where each tunnel is placed in its own subnet.  I couldn't find any documentation that would show that this has to be the case or this is best practice. 

I am configuring a scenario where there are two pairs of MDS, one pair per Data Center (Fabric A and B)

So for DC01

Fabric A switch ip address for each interface (there are four gigabit interfaces) are the following (IPs have been changed but concept should remain the same):

Switch A - DC01

GigabitEthernet6/1 - 1.1.1.1

GigabitEthernet6/2 - 1.1.1.2

GigabitEthernet6/3 - 1.1.1.3

GigabitEthernet6/4 - 1.1.1.4

Switch B - DC01

GigabitEthernet6/1 - 1.1.1.5

GigabitEthernet6/2 - 1.1.1.6

GigabitEthernet6/3 - 1.1.1.7

GigabitEthernet6/4 - 1.1.1.8

----------------------------------------

Switch A - DC02

GigabitEthernet6/1 - 2.2.2.1

GigabitEthernet6/2 - 2.2.2.2

GigabitEthernet6/3 - 2.2.2.3

GigabitEthernet6/4 - 2.2.2.4

Switch B - DC02

GigabitEthernet6/1 - 2.2.2.5

GigabitEthernet6/2 - 2.2.2.6

GigabitEthernet6/3 - 2.2.2.7

GigabitEthernet6/4 - 2.2.2.8

Does anyone see any issues that might arise if tunnels are not necessarily placed in their own subnet? 

I have added the full configuration of Switch A and B for DC01 at the very bottom for further clarification.

------------------------------

Switch DC01_A

fcip profile 1

ip address 1.1.1.1

fcip profile 2

ip address 1.1.1.2

fcip profile 3

ip address 1.1.1.3

fcip profile 4

ip address 1.1.1.4

vsan database

vsan 10

interface port-channel 10

switchport trunk allowed vsan 10

interface fcip1

channel-group 10 force

no shutdown

use-profile 1

peer-info ipaddr 2.2.2.1

interface fcip2

channel-group 10 force

no shutdown

use-profile 2

peer-info ipaddr 2.2.2.2

interface fcip3

channel-group 11 force

no shutdown

use-profile 3

peer-info ipaddr 2.2.2.3

interface fcip4

channel-group 10 force

no shutdown

use-profile 4

peer-info ipaddr 2.2.2.4

interface GigabitEthernet6/1

ip address 1.1.1.1 255.255.255.0

switchport mtu 3000

no shutdown

interface GigabitEthernet6/2

ip address 1.1.1.2 255.255.255.0

switchport mtu 3000

no shutdown

interface GigabitEthernet6/3

ip address 1.1.1.3 255.255.255.0

switchport mtu 3000

no shutdown

interface GigabitEthernet6/4

ip address 1.1.1.4 255.255.255.0

switchport mtu 3000

no shutdown

Switch DC01_B

fcip profile 1

ip address 1.1.1.5

fcip profile 2

ip address 1.1.1.6

fcip profile 3

ip address 1.1.1.7

fcip profile 4

ip address 1.1.1.8

vsan database

vsan 10

interface port-channel 10

switchport trunk allowed vsan 10

interface fcip1

channel-group 10 force

no shutdown

use-profile 1

peer-info ipaddr 2.2.2.5

interface fcip2

channel-group 10 force

no shutdown

use-profile 2

peer-info ipaddr 2.2.2.6

interface fcip3

channel-group 11 force

no shutdown

use-profile 3

peer-info ipaddr 2.2.2.7

interface fcip4

channel-group 10 force

no shutdown

use-profile 4

peer-info ipaddr 2.2.2.8

interface GigabitEthernet6/1

ip address 1.1.1.5 255.255.255.0

switchport mtu 3000

no shutdown

interface GigabitEthernet6/2

ip address 1.1.1.6 255.255.255.0

switchport mtu 3000

no shutdown

interface GigabitEthernet6/3

ip address 1.1.1.7 255.255.255.0

switchport mtu 3000

no shutdown

interface GigabitEthernet6/4

ip address 1.1.1.8 255.255.255.0

switchport mtu 3000

no shutdown

3 REPLIES 3
vjmendoza
Enthusiast

I forgot to mention that I will have host static routes for reachability

So from Switch A DC01

ip route 2.2.2.1 255.255.255.255 interface gigabitethernet 6/1

ip route 2.2.2.2 255.255.255.255 interface gigabitethernet 6/2

ip route 2.2.2.3 255.255.255.255 interface gigabitethernet 6/3

ip route 2.2.2.4 255.255.255.255 interface gigabitethernet 6/4

Hi,

Create a port-channel with 3 interfaces is not a best practice, it works, but you don't have a good load balancing among them.

To high availability you may also use vrrp or even leave two fc-port-channels as you did.

Set up the write acelerator and windowing options is always good.

Regards.

Richard

Content for Community-Ad
This widget could not be displayed.