Showing results for 
Search instead for 
Did you mean: 

UCS connection to McData SAN infrastructure


I'm trying to connect an UCS to a SAN based on McData SAN switches. I configured the WWN pools and the vHBAs. The SAN Admin told me, NPV is on the port activated and NPIV is supported.

On the swicthes, my WWPNs are visible and the SAN Admin configured the zoning and the presentation already. If I rescan the the SAN on my ESX, I can't see any path or presentated LUNs at all. LIP reset with no success.

in the past, I had access to the whole environment and there was no special configuration to get this working. At this time I was working with Brocade/HP SAN switches. Today I'm only responsible for the UCS an the vSphere environment and the other admins have no experience with UCS.

Any tips or hints will be very helpfull tu get this working. Do I have to make any special configurations? Does anyone have experience with UCS and McData SAN and can share the needed configurations with me?

Kind Regards


4 Replies 4

Cisco Employee
Cisco Employee

Hello Bastian,

Can you please verify if WWPN did flogi into UCS FI and Brocade switch ?


connect nxos

show npv flogi-table

What is the UCSM version  ?

Share the output of following commands if the blade is installed with Cisco VIC card

connect adapter 1/1/1     ### here connecting to adapter 1 of server 1 in Chassis 1 ( C/S/A )




login ID

lunmap ID

lunlist  ID

where ID is the vnic ID



many thanks for your help.

show npv flogi-table shows:


SERVER                                                                  EXTERNAL




vfc791    1000 0x636215 20:00:00:25:b5:10:a1:00 20:00:00:25:b5:10:c1:00 fc2/1

vfc793    1000 0x636214 20:00:00:25:b5:10:a1:01 20:00:00:25:b5:10:c1:03 fc2/1

vfc795    1000 0x636217 20:00:00:25:b5:10:a1:02 20:00:00:25:b5:10:c1:01 fc2/1

vfc797    1000 0x636218 20:00:00:25:b5:10:a1:03 20:00:00:25:b5:10:c1:02 fc2/1

vfc805    1000 0x636216 20:00:00:25:b5:10:a1:04 20:00:00:25:b5:10:c1:04 fc2/1

UCSM Version is 2.1(3a)

adapter 1/1/1 # connect

adapter 1/1/1 (top):1# attach-fls

adapter 1/1/1 (fls):1# vnic

---- ---- ---- ------- -------

vnic ecpu type state   lif

---- ---- ---- ------- -------

8    1    fc   active  5

9    2    fc   active  6

adapter 1/1/1 (fls):2# login 8

lifid: 5

  ID   PORTNAME                 NODENAME                 FID

adapter 1/1/1 (fls):3# lunmap 8

adapter 1/1/1 (fls):4# lunlist 8

% Command not found

adapter 1/1/1 (fls):5# login 9

lifid: 6

  ID   PORTNAME                 NODENAME                 FID

adapter 1/1/1 (fls):6# lunmap 9

adapter 1/1/1 (fls):7#

No output at login doesn't sound good. Is this a fault of PLOGI didn't done correct? lunlist command not found is strange. Did this commend only works after successful login?

Kind Regards


Hello Bastian,

I assume the OS is booting from local disk and is not able to access LUN from SAN array.

In that case, adapter command output is normal.

Which vfc interface is bound adapter 1/1/1 ?

If the HBA has logged into FI / SAN switch, can you please double check the zoning configuration ?


Hi Padma,

you are correct, the server booting from local disk. Adapter 1/1/1 is bound to vfc797

sh int vfc797

vfc797 is trunking

    Bound interface is Vethernet8989

    Port description is server 1/1, VHBA hba_01

    Hardware is Virtual Fibre Channel

    Port WWN is 23:1c:54:7f:ee:11:50:bf

    Admin port mode is F, trunk mode is on

    snmp link state traps are enabled

    Port mode is TF

    Port vsan is 1

    Trunk vsans (admin allowed and active) (1)

    Trunk vsans (up)                       (1)

    Trunk vsans (isolated)                 ()

    Trunk vsans (initializing)             ()

    1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec

    1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec

      7631 frames input, 829888 bytes

        0 discards, 0 errors

      7631 frames output, 730680 bytes

        0 discards, 0 errors

    last clearing of "show interface" counters never

I will contact the SAN admin to recheck the zoning config.

Thanks for your help.