Hey Guys today I'm gonna show you the way to configure Voice and Data vlan on the same port on Cisco Switch CBS 300 Series. And I have two options to archive this.
Scenario:
I have created Voice Vlan (VLAN 10) and Data Vlan (VLAN20) and Native Vlan (VLAN 30) on my cisco switch CBS 300 series and I want to configure voice and data vlan into the same switch's port in order to use Telephone(Non-Cisco Phone) and Internet at the same times since I have only 1 network port.
Option 1:
SW-0010(config)# interface g1
SW-0010(config-if)#description Connected_to_Voice_Data_VLANs
SW-0010(config-if)#switchport mode general
SW-0010(config-if)#switchport general allowed vlan add 10 tagged
SW-0010(config-if)#switchport general allowed vlan add 20 untagged
SW-0010(config-if)#switchport general pvid 20
SW-0010(config-if)#lldp receive
SW-0010(config-if)#lldp transmit
SW-0010(config-if)# exit
SW-0010(config)#interface g24
SW-0010(config-if)#switchport mode trunk
SW-0010(config-if)#switchport trunk allowed vlan add 10,20,30
SW-0010(config-if)#end
Option 2: If option 1 doesn't work we need to try option by force switch to static voice vlan( by default switch will choose voice vlan automatically)
SW-0010(config)#voice vlan id 10
SW-0010(config)# interface g1
SW-0010(config-if)#description Connected_to_Voice_Data_VLANs
SW-0010(config-if)#switchport mode general
SW-0010(config-if)#switchport general allowed vlan add 10 tagged
SW-0010(config-if)#switchport general allowed vlan add 20 untagged
SW-0010(config-if)#switchport general pvid 20
SW-0010(config-if)#lldp receive
SW-0010(config-if)#lldp transmit
SW-0010(config-if)# exit
SW-0010(config)#interface g24
SW-0010(config-if)#switchport mode trunk
SW-0010(config-if)#switchport trunk allowed vlan add 10,20,30
SW-0010(config-if)#end
Hopefully this short guild should help you to solve these problems.
Thanks.
Chantha from Cambodia.