cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1776
Views
0
Helpful
14
Replies
Highlighted
Beginner

4500X VSL is down before switch convert mode virtual

 

@Reza Sharifi

Hi,

I've a pair of 4500X which had to be converted into VSS, now before converting the switch mode to virtual the VSL should be up But mine is not.

 

Below is my VSL configuration and the Warning that I get when applying Port-channel on the physical interfaces

***** Also attached some show outputs of logical and physical interfaces*******

 

Switch(config)#switch virtual domain 165
Domain ID 165 config will take effect only
after the exec command 'switch convert mode virtual' is issued

Switch(config-vs-domain)#switch 1
Switch(config-vs-domain)#switch 1 priority 200
Switch(config-vs-domain)#exit
!
Switch(config)#int port-channel 39
Switch(config-if)#switchport
Switch(config-if)#switch virtual link 1
WARNING:Port channel number for VSL on both chassis should not be same

!

Switch(config)#int range te 1/1-2
Switch(config-if-range)#channel-group 39 mode on

 

WARNING: Interface TenGigabitEthernet1/1 placed in restricted config mode. All extraneous configs removed!
*Jan 28 05:14:15.787: %EC-5-CANNOT_BUNDLE2: Te1/1 is not compatible with Po39 and will be suspended (trunk mode of Te1/1 is dynamic, Po39 is trunk)
WARNING: Interface TenGigabitEthernet1/2 placed in restricted config mode. All extraneous configs removed!
*Jan 28 05:14:16.986: %EC-5-CANNOT_BUNDLE2: Te1/2 is not compatible with Po39 and will be suspended (trunk mode of Te1/2 is dynamic, Po39 is trunk)

 

******* On the other hand second switch has exactly the same issue  ********

 

I cannot convert the switch mode to virtual unless the VSL that's connecting both the chassis is up and running. 

Any solution to get it up so I can run 'switch convert mode virtual' command?

 

**** It'd be great if you can also tell me whether I've to set-up different hostnames on both the switches  for identification purpose Or after VSS creation only the hostname of active switch will appear on both active and standby chassis ****

 

Kind Regards,

14 REPLIES 14
Highlighted
VIP Mentor

Hi 

 

This post is redundant with your other post:

https://supportforums.cisco.com/t5/wan-routing-and-switching/4500x-vsl-issue/td-p/3320439

 

Have you tried doing as I told previously:

- remove port-channel

- do default interface for both ports

- configure your interfaces

- add channel-group on your interface

- configure your port-channel

- add switch virtual link under your port channel

 

Let's try this and keep us posted.

 

In terms of hostname, at the end you'll have the active hostname visible on both chassis.

 

 


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Highlighted
Hall of Fame Expert

Hi,

WARNING:Portchannel number for VSL on both chassis should not be same

Are you using the same Portchannel number for both chassis and all 4 interfaces?  You need 2 different Portchannels with every 2 links in a different one.

Example, 

po139 will have 2 10Gig links init

and 

Po140 will have the other 2Gig links init.

Also, there is really no need for this command:

switch 1 priority 200

After converting to VSS and rebooting both chassis at the same time, by default switch-1 will always be the primary and switch-2 will be the standby.

As for your other question, once converted to VSS, the hostname will be the primary switch's name and that switch will override all the configs on the standby switch. When converting to VSS, it is a good idea to start with no configs on both switches.

HTH

Highlighted

Thanks for your imputs Reza,

 

Yes both have different port-channels configured for VSL.

 

I wanted to know whether I can convert both switches to virtual whilst having the VSL down and physical ports in suspended state OR it is mandatory to bring the VSL up prior to the conversion.

 

Highlighted

to create the virtual switch VSL should be up

"Configuring VSL is the second step in creating a virtual switch (after defining the domain ID).

https://www.cisco.com/c/en/us/td/docs/solutions/Enterprise/Campus/VSS30dg/campusVSS_DG/VSS-dg_ch2.html#wp1056015
Highlighted

Hi Umar,

The VSL needs to be up prior to conversion.

HTH

Highlighted

Thanks again Reza, but my VSL isn't coming up I've tried almost everything.

 

Please see the attached files containing all the configs and show outputs.

 

'switchport nonnegotiate' command helped me to resolve the issue of dynamic trunking on physical interfaces but port-channel is still down and connected ports are in suspended state.

 

 

Highlighted

Can you completely delete the Portchannels on both switches and start again?

Also, can you default all the physical interfaces and start again?

After the deletion, make sure the physical ports you want to use are in up and up mode

If yes, go to the first physical interface and add it to the Po you want

example:

 

on switch-1 

Interface te1/1

switchport 
channel-group 39 mode on

 

Interface te1/2

switchport 
channel-group 39 mode on

 

on switch-2 

Interface te1/1

switchport 
channel-group 40 mode on

 

Interface te1/2

switchport 
channel-group 40 mode on

 

Then go to the po39  and 

switchport
switchport mode trunk
switchport nonegotiate
switch virtual link 1

 

Then go to the po40  and 

switchport
switchport mode trunk
switchport nonegotiate
switch virtual link 2

Can you try these and post results?

HTH

Highlighted

@Reza Sharifi  

 

I can try to assign ports to the port-channels before making them switch virtual links.

 

But in this case I think switch might reject the commands by saying:

 

You are configuring VSL on interface Po39.

There are member ports already attached to the port channel.
Remove all member ports before configuring as VSL Port-Channel.

 

What do you say?

Highlighted

Well, if you delete the existing Portchannles and default the interfaces, you should be able to do this.

Also, have a look at this document

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/15-1-2/XE_340/configuration/guide/config/vss.html#wp1055875

HTH

Highlighted

I tried but got the same msg: "Member ports are already attached to this port-channel. Remove all member ports before configuring VSL port-channel".

 

And upon configuring them again with VSL port-channel, physical ports are now again suspended members of VSL port-channel.

 

One more thing, on my switches vstack is disabled with 'no vstack' global configuration command. Do you think this is causing issues on VSL ?

Highlighted
VIP Mentor

Duplicate post

 

Please close either one of them - here



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Yes, I always rate helpful answers cause I respect the efforts of all the supports community members.

 

In fact, the other post was created to discuss the issue of dynamic trunking (%EC-5-CANNOT_BUNDLE2) on VSL port-channels.

 

 

Highlighted

Hello
As others have suggested in this post and the other one you have open - when creating a VSL PC, its best to let the PC get created automatically.

Did you try the following?

1) delete any related Logical PC you wish to use as the vsl

2) default the physical interface of the PC and SHUT them down.

3) assign Just the port-channel group X ON mode to the physical interfaces ( PC wil get created)

4) apply virtual link number to pc and create VSL config
5) enable physical interfaces

default int ran x/x ,x
int ran x/x , x
shut
channel-group X mode on

int port-channel x
switchport
switch virtual-link x
no shut

switch virtual domain xx
switch x

int ran x/x , x
no shut



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Brother Paul,

 

I've tried this several times but when you run the 'switch virtual link' command on an existing port-channel that was automatically created whilst calling it on physical ports, the switch rejects the command by saying "Remove the member ports before configuring a VSL port-channel".

 

Now when I remove the ports and configure the VSL port-channel and then apply it on physical ports they become suspended members of port-channel again.

 

I was watching below video on YouTube

 

https://www.youtube.com/watch?v=yJPVBFJzcok&t=4s

 

he got exactly the same suspension warning but he proceeded with 'switch convert mode virtual' command without even brining the VSL up.

 

I'm not sure whether it will work or put my switches into ROMMON due to failure of VSL and VSS conversion.

Content for Community-Ad