cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

399
Views
10
Helpful
6
Replies
Highlighted
NGJ Beginner
Beginner

Add network statement to exsiting OSPF config

Hi, quick query to confirm I'm adding OSPF statements correctly.

 

On our core L3 switch we have an existing ospf config (ive left out all details apart from one example) i.e.

 

router ospf 1

  router-id x.x.x.x

  network 10.10.10.0 0.0.0.255  area 0

 

If I want to add another network statement

  network 10.10.20.0 0.0.0.255 area 0

 

Do I just go into the 'router ospf 1' sub command and add the additional statement - or will this overwrite what already exists there?

 

Thanks

 

Thanks

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Expert

Re: Add network statement to exsiting OSPF config

Hi,

You just go under ospf router and add the new command.  It will not override the other one as this is a new statement.

config t

router ospf 1

network 10.10.20.0 0.0.0.255 area 0

 

HTH

6 REPLIES 6
VIP Expert

Re: Add network statement to exsiting OSPF config

Hi,

You just go under ospf router and add the new command.  It will not override the other one as this is a new statement.

config t

router ospf 1

network 10.10.20.0 0.0.0.255 area 0

 

HTH

NGJ Beginner
Beginner

Re: Add network statement to exsiting OSPF config

Thanks for the confirmation.  Its as I hoped/expected but needed confirmation before I tried.

Participant

Re: Add network statement to exsiting OSPF config

alternatively:

interface fa0/1

 ip ospf 1 area 0

regards

mk

NGJ Beginner
Beginner

Re: Add network statement to exsiting OSPF config

Thanks for the alternative option
NGJ Beginner
Beginner

Re: Add network statement to exsiting OSPF config

Thanks for the alternative option

VIP Advisor

Re: Add network statement to exsiting OSPF config

Hello

 


@NGJ wrote:

Hi, quick query to confirm I'm adding OSPF statements correctly.

 

On our core L3 switch we have an existing ospf config (ive left out all details apart from one example) i.e.

 

router ospf 1

  router-id x.x.x.x

  network 10.10.10.0 0.0.0.255  area 0

 

If I want to add another network statement

  network 10.10.20.0 0.0.0.255 area 0

 

Do I just go into the 'router ospf 1' sub command and add the additional statement - or will this overwrite what already exists there?

 


you can do that or another option is you can apply it via the actual interface you want advertising

 

int x/x

ip ospf 1 area 0



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards