cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

310
Views
0
Helpful
0
Replies
Highlighted
Beginner

ASR1002 PPPoE Server virtual-access snmp traps linkdown linkup not work

Hi!

 

Were are migrating a BRAS from Cisco 3745 to ASR1002.

We have all set, except for one problem, the ASR it's not generating trap messages on virtual-access link status events. snmp link-status event works fine with static interfaces. I did an upgrade on ASR from 12.2 to 15.1 but still the same result. something more strange is that, it a session is established, and then i perform "snmp trap link-status" on virtual-template, when client goes down the server generates linkdown snmp trap. Don't know if i need to configure something but we need this working to finish the migration process cause this trap is essential to track user traffic.

Something that i notice is that ASR do not support Full ViA interface, need to enable something for this?

 Ps.: On 3745 all works fine. Im debuging trap packets via snmp debug packets and wireshark on the other end.

My sh version is:

Cisco IOS Software, IOS-XE Software (PPC_LINUX_IOSD-ADVIPSERVICESK9-M), Version 15.1(1)S1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 10-Feb-11 23:51 by mcpre


Cisco IOS-XE software, Copyright (c) 2005-2011 by cisco Systems, Inc.
All rights reserved. Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0. The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0. For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.


ROM: IOS-XE ROMMON

hub.manosnet.com.br uptime is 3 days, 1 hour, 44 minutes
Uptime for this control processor is 3 days, 1 hour, 46 minutes
System returned to ROM by reload at 09:30:47 BR Sat Jul 21 2018
System image file is "bootflash:/asr1000rp1-advipservicesk9.03.02.01.S.151-1.S1.bin"
Last reload reason: Reload Command

 

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco ASR1002 (2RU) processor with 1713474K/6147K bytes of memory.
4 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
32768K bytes of non-volatile configuration memory.
4194304K bytes of physical memory.
7798783K bytes of eUSB flash at bootflash:.

Configuration register is 0x2102

 

and my current config is:

!
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname #ommited#
!
boot-start-marker
boot-end-marker
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
aaa new-model
!
!
aaa authentication login console local
aaa authentication ppp default group radius
aaa authorization exec console local 
aaa authorization network default group radius 
aaa accounting delay-start
aaa accounting update periodic 5
aaa accounting include auth-profile framed-ip-address
aaa accounting include auth-profile framed-ipv6-prefix
aaa accounting include auth-profile delegated-ipv6-prefix
aaa accounting network default start-stop group radius
aaa accounting system default start-stop group radius
!
!
!
!
aaa server radius dynamic-author
 server-key ciscomanos
 port 3799
 auth-type any
 ignore session-key
!
aaa session-id common
aaa policy interface-config allow-subinterface
clock timezone BR -3
ip source-route
!
!
ip name-server #ommited#
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
username #ommited#
username #ommited#
!
redundancy
 mode none
! 
!
!
!
!
ip tftp source-interface GigabitEthernet0/0/0.21
!
bba-group pppoe manosnet
 virtual-template 1
 sessions auto cleanup
!
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.0
!
interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/0.21
 encapsulation dot1Q 21
 ip address #ommited# 255.255.255.248
!
interface GigabitEthernet0/0/1
 no ip address
 ip virtual-reassembly
 negotiation auto
 pppoe enable group manosnet
!
interface GigabitEthernet0/0/2
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/3
 no ip address
 negotiation auto
!
interface TenGigabitEthernet0/1/0
 no ip address
 shutdown
!
interface TenGigabitEthernet0/2/0
 no ip address
 shutdown
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 ip address 192.168.49.6 255.255.255.252
 negotiation auto
!
interface Virtual-Template1
 mtu 1492
 ip unnumbered Loopback0
 no ip redirects
 ip virtual-reassembly
 ip tcp adjust-mss 1452
logging event subif-link-status peer default ip address pool pppoe-pool keepalive 60 ppp mtu adaptive ppp authentication pap ppp multilink ! ip local pool pppoe-pool 10.0.0.2 10.0.0.254 ! no ip http server no ip http secure-server ip route 0.0.0.0 0.0.0.0 #ommited# ! snmp-server group leaf_snmp v3 auth snmp-server community public RO 1 snmp-server enable traps snmp linkdown linkup snmp-server host #ommited# version 3 auth leaf_snmp ! radius-server attribute 6 on-for-login-auth radius-server attribute 8 include-in-access-req radius-server host #ommited# auth-port 1812 acct-port 1813 radius-server key ciscomanos radius-server vsa send accounting radius-server vsa send authentication ! control-plane ! ! ! line con 0 stopbits 1 line aux 0 stopbits 1 line vty 0 4 authorization exec console ! ntp server 200.160.0.8 end

 

Everyone's tags (5)
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards