12-28-2012 01:04 PM - edited 03-07-2019 10:49 AM
I want to restrict the amount of bandwidth that is being consumed by our backup between two servers. We have a server that is connected to switch A that is at 10.1.1.1 that is going accross our network to 10.2.1.1. How do I put something in our routed network that will restrict the bandwidth between these two IP's. I am assuming this a police statement and could be applied on the outbound switchport.
Thank you in advance for your help.
12-28-2012 01:10 PM
Is this a LAN or is this happening over the WAN? Also is this a private network? Because if you limit the bandwidth then it will apply to it period all the time.
12-28-2012 01:13 PM
It is going accross the LAN.
12-28-2012 07:16 PM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Police statement could be one way to do it. Generally you want to police as close to the source as possible, ideally the sending host's ingress port.
An alternative approach is to have active QoS that prioritizes traffic differently. For sometime like a backup traffic, you could allow it all available bandwidth, but with minimum priority.
12-29-2012 03:17 AM
Do you have a suggestion on how to write the code for this?
12-29-2012 03:30 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Do you have a suggestion on how to write the code for this?
I, or others, might be able to suggest something, but we would need to know the exact device kind and, if a router, its IOS version.
12-31-2012 10:23 AM
Also a brief network topology with IP's would be helpful. I'm curious if it is happening over LAN and backups usually happen at night why do you want to limit the bandwidth? It will take longer for the backup to complete.
12-31-2012 01:03 PM
Here's what I came up with. See any problems?
3750G# config t
3750G(config)# ip access-list extended TO_BACKUP_SERVER
3750G(config-ext-nacl)# permit ip host 10.1.1.1 host 10.2.1.1.
3750G(config-ext-nacl)# exit
3750G(config)# class-map tcp
3750G(config-cmap)# match access-group TO_BACKUP_SERVER
3750G(config-cmap)# exit
3750G(config)# policy-map LIMIT
3750G(config-pmap)# class tcp
3750G(config-pmap-c)# police 100000000 8000 exceed-action drop
3750G(config)# interface vlan 1
3750G(config-if)# service-policy input LIMIT
For the Return traffic
2950# config t
2950(config)# ip access-list extended TO_MAIN_SERVER
2950(config-ext-nacl)# permit ip host 10.1.1.1 host 10.2.1.1
2950(config-ext-nacl)# exit
2950(config)# class-map tcp-return
2950(config-cmap)# match access-group TO_MAIN_SERVER
2950(config-cmap)# exit
2950(config)# policy-map LIMIT-RETURN
2950(config-pmap)# class tcp-return
2950(config-pmap-c)# police 100000000 8000 exceed-action drop
2950(config)# interface vlan 40
2950(config-if)# service-policy input LIMIT-RETURN
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide