cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
566
Views
15
Helpful
6
Replies
suthomas1
Frequent Contributor

basic setup help

Hello,

We have two routers, one for local lan users & other for voip.
local lan users are on vlan 65 & voip on vlan 75
vlan 65 - 192.168.65.1 /24
vlan 75 - 192.168.75.1 /24

vlan 65 will also have printers, wireless & cameras.
can a single layer2 switch be used to connect both the segments. spanning tree should be accounted for.
Goal being local lan should go via router 1 & voip via router 2.


Kindly help please.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

Yes, you can use the same l2 switch for both VLAN, how the end devices will select what gateway? Basically you will have a connection between the router and the switch and also you will assign the gateway to the end device, for example:

 

Router A (vlan 65)

 

interface G0/0

description VLAN65-Gateway-TO-SWITCH

ip address 192.168.65.1 255.255.255.0

no shutdown

 

Switch L2

 

VLAN 65

name LAN-DATA

 

interface g1/1/1

description TO-ROUTER-A

switchport access vlan 65

switchport mode access

no shutdown

 

interface g1/0/1

description LAN-DATA-USER

switchport access vlan 65

switchport mode access

no shutdown

 

PC

 

IP address 192.168.65.100

Network mask: 255.255.255.0

Gateway: 192.168.65.1

 

* The configuration for VLAN 75 will be similar but with its differences.*

 

There is many ways to configure a network, now this configuration will isolate the VLAN 65 with the VLAN 75. A L2 switch cannot enable communication between the VLANs, now if you want to enable the communication you need to create intervlan routing or create routing between the routers. 

 

Hope it is useful

:-)

  




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

6 REPLIES 6
saif musa
Enthusiast

Yes, single layer2 switch can handle two segments via VLAN proccess, chick below

 

https://supportforums.cisco.com/t5/network-infrastructure-documents/how-to-configure-vlans-on-the-catalyst-switches/ta-p/3131780

 

Hope that help

 

Regards

 

suthomas1
Frequent Contributor

Thank you. How will layer 2 route to two different svi towards both routers. User vlan will have its own gateway while other vlan will have its own. & as there is only one layer 2 switch. 

 

Julio E. Moisa
VIP Mentor

Hi

Could you please share how is your current topology? or what is your goal? You could have something like:

 

Router 1                     Router 2

            \                   /

         vlan65         vlan75

              \               /

                L2 Switch

 

The end devices will use the specific gateway, now if you want communication between them you need to enable rounting between the Routers.

 

Hope it is useful

:-)

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Thanks. That is similar to what I was referring to. Can all users (both vlans) be on same layer 2 switch with svi on individual router? & how will layer 2 switch determine gateway as both subnet are different. 

Appreciate response. 

Hi,

Yes, you can use the same l2 switch for both VLAN, how the end devices will select what gateway? Basically you will have a connection between the router and the switch and also you will assign the gateway to the end device, for example:

 

Router A (vlan 65)

 

interface G0/0

description VLAN65-Gateway-TO-SWITCH

ip address 192.168.65.1 255.255.255.0

no shutdown

 

Switch L2

 

VLAN 65

name LAN-DATA

 

interface g1/1/1

description TO-ROUTER-A

switchport access vlan 65

switchport mode access

no shutdown

 

interface g1/0/1

description LAN-DATA-USER

switchport access vlan 65

switchport mode access

no shutdown

 

PC

 

IP address 192.168.65.100

Network mask: 255.255.255.0

Gateway: 192.168.65.1

 

* The configuration for VLAN 75 will be similar but with its differences.*

 

There is many ways to configure a network, now this configuration will isolate the VLAN 65 with the VLAN 75. A L2 switch cannot enable communication between the VLANs, now if you want to enable the communication you need to create intervlan routing or create routing between the routers. 

 

Hope it is useful

:-)

  




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Thanks again. If vlan 65 is configured as mgmt interface on layer 2 & default gateway for layer2 switch be 192.168.65.1, will that be ok?

also, Is it possible to use SVI for both vlans on both routers individually instead of layer3 physical interface as your configuration says. 

Both routers have a connection to another two routers that come from service providers & they both have use layer3 on physical.

appreciate if config for this way ( svi on routers & relevant on layer2) be shown so it will help.