11-13-2014 02:15 AM - edited 03-07-2019 09:29 PM
hi
I need help about Cisco switch 2960 issue how i give IP address gateway in switch if there more than two vlan and how configure telnet command
plz help me
11-13-2014 03:51 AM
You can have one management vlan available. Let's say it's vlan 1 which is default. To configure:
int vlan 1
ip address 192.168.1.1 255.255.255.0
no shut
A basic telnet session is:
line vty 0 4
password cisco
You can get more granular with usernames like using local accounts and radius authentication for telnet as well. You'll also need an enable password before you can telnet:
enable secret cisco
HTH,
John
11-13-2014 03:56 AM
thanks a lot john
if we create extra vlan and not access any interface and just give ip address and not shut command then it work
11-13-2014 04:00 AM
Hi,
Do you have Lan Lite or Lan Base license (check with "show version")? LAN LITE does not permit routing.
With LAN BASE:
sdm prefer lanbase-routing // save before your config, you may loose some configuration
reload the switch
Example for gateway configuration:
vlan 10
vlan 20
interface vlan 10
ip address 10.0.10.1 255.255.255.0
interface vlan 20
ip address 10.0.20.1 255.255.255.0
For telnet:
username name privilege 15 secret password
line vty 0 15
login local
transport input all
But, do not use telnet (all traffic passes on clear including passwords), use instead ssh if the switch permits:
hostname switch
ip domain name company.com
crypto key generate rsa general-keys modulus 2028
line vty 0 15
login local
transport input ssh
Hope this could help you!
Regards,
Pedro Lereno
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide