01-24-2015 06:57 AM - edited 03-07-2019 10:22 PM
I have Cox Cable with a DHCP IP address. I want to connect my cable modem to my 3750. I have fa1/0/1 connected to the modem. I have a few other devices I would like to connect to the rest.
I can get an IP from Cox on fa1/0/1. My switch will pass out IP's to the devices that connect to it. NONE of those devices can connect to the internet.
What am I doing wrong?
mikeroswitch#sho run
Building configuration...
Current configuration : 3786 bytes
!
! Last configuration change at 06:07:35 UTC Thu Jan 22 2015
! NVRAM config last updated at 06:07:39 UTC Thu Jan 22 2015
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname mikeroswitch
!
no logging console
enable secret 5 $1$OCX1$xPVzdxIbA1dzoEhNaNiE/1
!
no aaa new-model
switch 1 provision ws-c3750-48p
ip subnet-zero
ip dhcp excluded-address 10.10.17.1
!
ip dhcp pool HOME
import all
network 10.10.17.0 255.255.255.0
default-router 10.10.17.1
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
vlan internal allocation policy ascending
!
!
interface FastEthernet1/0/1
no switchport
ip address dhcp
!
interface FastEthernet1/0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/7
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/8
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/9
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/10
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/17
shutdown
!
interface FastEthernet1/0/18
shutdown
!
interface FastEthernet1/0/19
shutdown
!
interface FastEthernet1/0/20
shutdown
!
interface FastEthernet1/0/21
shutdown
!
interface FastEthernet1/0/22
shutdown
!
interface FastEthernet1/0/23
shutdown
!
interface FastEthernet1/0/24
shutdown
!
interface FastEthernet1/0/25
shutdown
!
interface FastEthernet1/0/26
shutdown
!
interface FastEthernet1/0/27
shutdown
!
interface FastEthernet1/0/28
shutdown
!
interface FastEthernet1/0/29
shutdown
!
interface FastEthernet1/0/30
shutdown
!
interface FastEthernet1/0/31
shutdown
!
interface FastEthernet1/0/32
shutdown
!
interface FastEthernet1/0/33
shutdown
!
interface FastEthernet1/0/34
shutdown
!
interface FastEthernet1/0/35
shutdown
!
interface FastEthernet1/0/36
shutdown
!
interface FastEthernet1/0/37
shutdown
!
interface FastEthernet1/0/38
shutdown
!
interface FastEthernet1/0/39
shutdown
!
interface FastEthernet1/0/40
shutdown
!
interface FastEthernet1/0/41
shutdown
!
interface FastEthernet1/0/42
shutdown
!
interface FastEthernet1/0/43
shutdown
!
interface FastEthernet1/0/44
shutdown
!
interface FastEthernet1/0/45
shutdown
!
interface FastEthernet1/0/46
shutdown
!
interface FastEthernet1/0/47
shutdown
!
interface FastEthernet1/0/48
shutdown
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 10.10.17.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet1/0/1
ip http server
!
!
!
!
!
control-plane
!
banner motd ^C Mi^C
!
line con 0
password 7 1214121443535F50
login
speed 115200
line vty 0 4
password 7 1214121443535F50
no login
line vty 5 15
password 7 0009040555035852
no login
!
!
end
01-27-2015 05:23 AM
There are a few things you need to do -
1) the cable modem needs to have route back to your 10.10.17.0/24 subnet so if it doesn't have one you need to add a route on the modem pointing back to the 3750
2) you need will need to setup NAT for the 10.10.17.0/24 subnet on the cable modem
However some cable modems will not allow you to do either (I have no experience of the modem you are using).
Adding a route should be easier but often modems such as this will not allow it.
In addition some cable modems will only NAT for the directly connected IP subnet ie. the one used between the 3750 and itself.
Your 10.10.17.0/24 is not directly connected.
So I'm not saying it won't allow you to do these things but it might well not.
If you can't then if you had a router instead of a L3 switch there is an easy solution because routers do NAT but virtually all L3 switches don't and yours doesn't.
So your only way of getting this to work with the L3 switch is put all your devices in a common vlan ie. the end devices and the connection to the cable modem are all in the same vlan.
But first see what the cable modem can do.
Jon
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide