Showing results for 
Search instead for 
Did you mean: 

Community Helping Community


Cannot bring SFP fiber interfaces up


I am trying to connect a 6509 switch to a 4503-E switch using single mode dark fiber over a distance of less than half a mile. Although a routine task, it does not work!

Here is the scenario:

We have a care 6509 switch where we concentrate all of our dark fiber connections for our remote sites. The 6509 switch already has 30 remote sites, most of them with 4503-E switches, connected in this way therefore it is a tested scenario. For the connections we use the GLC-LH-SM SFPs on both switches. Out of these 30 sites we had a similar problem with two of them, which we solved with the use of CWDM SFPs. With the CWDMs the fiber came up right away. However, I cannot keep using this solution because it is way too expensive! I had the losses of the fiber measured end-to-end and they are negligible (>0.5 dB).

In this latest case, like I said, we could not bring the connection up between the core 6509 switch and the 4503-E switch using the GLC-LH-SM SFPs. I then replaced the 4503-E switch with a 3560 and the link came up! Then I tried using a CWDM-SFP in the 4503-E, while keeping the GLC-LH-SM SFP in the 6509 and the link came alive again! Of course we already tried replacing the fiber patch cords with no luck.

Here is the info of the 6509 and 4503 switches:

6509 switch:

IOS- s72033-ipservicesk9_wan-mz.122-33.SXJ2.bin


Ethernet card- WS-X6748-SFP

4503-E switch:

IOS- cat4500e-entservicesk9-mz.122-44.SG1.bin


The GLC-LH-SM SFP are connected in the SUP.

Any ideas why this is happening? Could it be a bug? I find it very weird for the link to work with the 3560 or with a CWDM in the 4503 but NOT with the SFP in the 4503!

Everyone's tags (6)
VIP Expert

Re: Cannot bring SFP fiber interfaces up


On the 4500, are you using a TwinGig converter? If yes, did you change the mode to 1Gig?

Limitations on Using a TwinGig Convertor

In a Supervisor Engine 6-E system, the ports are connected to the  switching engine through a stub ASIC. This stub ASIC imposes some  limitations on the ports: Gig and 10 Gig ports cannot be mixed on a  single stub ASIC; they must either be all 10 Gig (X2), or all Gig  (TwinGig Converter and SFP). The faceplates of X2 modules show this stub  port grouping, either with actual physical grouping with a box drawn  around a grouping.

Selecting X2/TwinGig Convertor Mode

The default configuration mode is X2. So, if you plan to deploy  10-Gigabit interfaces, you don't need to configure anything. However, if  you want to deploy Gigabit interfaces (that is, use TwinGig  Convertors), you must configure the associated port-group:

To determine how the X2 holes on a module are grouped, enter the
show hw-module module port-group



Re: Cannot bring SFP fiber interfaces up

Hi Reza and thank you for the reply.

I am using a TwinGig converter and I changed the mode to 1 Gig. The CWDM-SFP, which is a 1 gig module, is recognized by the 4503-E switch and works. It just does not want to work when I use GLC-LH-SM SFPs end-to-end on the 6509 and 4503 switches!

Cisco Employee

Re: Cannot bring SFP fiber interfaces up


It could be a bug such as CSCtd40838   Valid GBICs May Be Declared as INCOMPATIBLE.

Did you check the syslogs for any errors, e.g. unsupported SFP message?

You can check the SFP information, such as manufacturer, using "show idprom int ..." command.

Also, have you tried with different set GLC-LH-SM SFPs, in case those you have used are faulty?

Kind Regards,
Ivan Shirshin

**Please grade this post if you find it useful.

Kind Regards, Ivan Shirshin **Please grade this post if you find it useful.

Re: Cannot bring SFP fiber interfaces up


I have no errors in the 4503 logs and the switch does recognize the SFP. If I connect the 4503 with another switch back to back using the GLC-LH-SM SFPs (the ones I have problems using for the dark fiber) it works.

Another thing I tried today was to use a SFP-GE-L SFP on the 4503. This one worked fine, like the CWDM did! The characteristics of the SFP-GE-L are the same like the GLC-LH-SM, except it has the DOM feature. CWDM also has the DOM feature. I started thinking that the DOM feature is what makes the difference here. If this is the case then it should be a bug, because like I said I have quite a lot of 4503 switches with identical hardware and IOS configuration but I have this problem with only 3 of them.

I will check into the bugs you are mentioning with the hope to find something! Thank you!


Cannot bring SFP fiber interfaces up

Did you check, if the SFP probably receive too much laser power?

We had similar effects while the connection distance was effectively too low.

Get yourself 2 pieces of 5-6 DB dampeners per fiber and recheck the link.

This helped us on a few occasions.

Best Regards


Cannot bring SFP fiber interfaces up

Hi Christian,

With the GLC-LH-SM SFPs I had no issue with the laser power, although I have it when using the CWDM SFPs and I have to use 10dB attenuators.

I resolved the problem with an IOS upgrade. It is not listed as a bug in Cisco and like I said in my original posting I only had the issue in 3 out of my 30 sites. Most of my 4503 switches were running cat4500e-entservicesk9-mz.122-53.SG and a few cat4500e-entservicesk9-mz.122-44.SG1 IOS. The problem was resolved when they were upgraded to

cat4500e-entservicesk9-mz.122-54.SG1. It is strange however, because the problem appeared on both the 122-44 and the 122-53 IOS!

Thank you for the follow up!

CreatePlease to create content
Content for Community-Ad