cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
13155
Views
28
Helpful
10
Replies

cat 9200 config register

cmarva
Enthusiast
Enthusiast

just curious if anyone has seen this particular symptom. One, and only one, of our 9200s comes up with out of box config every time it reboots. after looking into it, the config register was set to 0x142, so it made sense and is easy enough to work around.

so we set the config register to 0x102. a sho ver at that time showed:

Configuration register is 0x142 (will be 0x102 at next reload)

 

we rebooted it, and it came  up with out box config, and a show ver showed:

Configuration register is 0x142 (will be 0x102 at next reload)

 

this thing just will not change to 102. It has undergone many reboots, and still says the above. I personally have never seen this happen with any platform. 

this is a C9200L-24P-4G currently running v16.12.4. but it exhibited the same with previous versions.

 

has anyone seen anything like this, or might have some advice on what to do? Thanks

10 Replies 10

cmarva
Enthusiast
Enthusiast

Leo Laohoo
Hall of Fame
Hall of Fame

If the switch is in ROMMON, post the complete output to the following command:

set

that's the thing, it boots fine, just ignores nvram. Then we dial the modem (it's at a branch location), copy start tot urn and we're good until the next reboot. anyhow, I'm gonna try what's in this doc later tonight and see what happens


@cmarva wrote:

it boots fine, just ignores nvram.


ROMMON command "set" will show us if password recovery is enabled or not.

Maybe the boot-variable string for the config is configured to something else.

Hello
on cat9ks i think the config-register isn’t used or is ignored and boot commands are instead -try the following 

no boot manual


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

KalinKrumov
Beginner
Beginner

Hi,

 

I have the same problem.

I tested all of the things mentioned above, but they did not help me. The switch is 9200L, Version 17.3.4b

I configured a few switches with the same hardware and IOS but only one has this problem.

 

Regards,

Kalin

I resolved the problem after just typing the exact command "Write mem" or "Copy Run Start '' before "reload". During reload appear dialog, something as this:

 

Do you want to erase configuration (y,n,default)

I type "n" enter

 

The switch register now is 0x102 and looks well.

Benjamink4c
Beginner
Beginner

Reloaded the switch and went to ROMMON mode, change to boot from the startup-config

switch: SWITCH_IGNORE_STARTUP_CFG=0

The switch register is now Configuration register is 0x102.

All is OK now for me.

egill
Beginner
Beginner

I fixed the issue on my device with these commands:

no system ignore startupconfig switch all

config-register 0x102

kanchwalaliasgar
Beginner
Beginner

Hello Everyone,

I used this command to not ignore startup-config switch: SWITCH_IGNORE_STARTUP_CFG=0, but whenever i reload it goes back to romon mode, can someone please help?

Shw Ver: configuration register is 0x102 - i did some research and is looks like i need to change register so that it will boot startup-config but none of the available commands are working for me.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: