cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

445
Views
0
Helpful
4
Replies
Highlighted
Beginner

changing native vlan on 3550 switch

Hello, I am having trouble after creating a management vlan (99) on a 3550 switch.

I have configured the vlan (99) and given it an IP (192.168.1.100) and a default gateway (my router address - 192.168.1.99).

I can ping to the switch from a PC and vice versa. The management VLAN IP is fine but now I cannot ping to the router from either the PC or the switch.

It seems that just by adding VLAN 99 with it's own IP address has now prevented pings from the switch/PC to the router ?

Due to the fact that I have created a new switch management VLAN with an IP, does this mean I have set up the router as a 'router on a stick' scenario ?

Can anyone offer any advice. Thanks kindly.

SWITCH:

Current configuration : 1773 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname philSwitch

!

enable secret 5 $1$ilmv$Y.Tk4P.YHv9YW5QUziuLd/

!

ip subnet-zero

no ip domain-lookup

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

switchport access vlan 99

switchport mode access

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no ip address

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

no ip address

shutdown

!

interface Vlan99

ip address 192.168.1.100 255.255.255.0

!

ip default-gateway 192.168.1.99

ip classless

ip http server

!

!

!

line con 0

exec-timeout 0 0

password cisco

logging synchronous

login

line vty 0 4

login

line vty 5 15

login

!

end

ROUTER:

Current configuration : 2815 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname phils2801Router

!

boot-start-marker

boot system flash:c2801-ipvoicek9-mz.151-2.T0a.bin

boot-end-marker

!

!

enable secret 5 $1$EoXZ$H4m7dIwwMn/drqZZqoLV./

!

no aaa new-model

dot11 syslog

ip source-route

!

!

!

ip cef

no ip domain lookup

no ipv6 cef

multilink bundle-name authenticated

!

!!

voice-card 0

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.99 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

!

!

ip http server

ip http authentication local

ip http secure-server

!

logging esm config

!

!

!

control-plane

!

!

!

mgcp fax t38 ecm

!

!

!

!

telephony-service

max-conferences 4 gain -6

transfer-system full-consult

!

!

line con 0

password cisco

logging synchronous

login

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

4 REPLIES 4
Highlighted
Hall of Fame Expert

changing native vlan on 3550 switch

Hi,

Did you also create the layer-2 vlan on the switch?

vlan 99

name mgmt-vlan

exit

is interface FastEthernet0/1 in up and up mode?

on the router

sh ip int bri

HTH

Highlighted
Rising star

changing native vlan on 3550 switch

Hi,

How  router and switch are connected to each other(ports)? Configure port that connected to router as access port on VLAN 99. F0/9 is port connected to PC?

Hope it will help.

Best regards,
Abzal
Highlighted
Advocate

Re: changing native vlan on 3550 switch

Hi Philip,

If everything was working before and stopped by just adding SVI then turn on ip routing on your switch by running the command "ip routing". You are creating SVI for VLAN99 making it a routed VLAN, but you dont have routing process ON on the switch.

Terry

Highlighted
Beginner

changing native vlan on 3550 switch

Hi Philip,

I guess the first question would be if the router is connected to switch. If router is on the same layer 2 vlan as your PC then you should be able to ping it. But by the description of your problem it appears that your router is not connected the same vlan.

Remember that when you configure SVI, the ip address that you give to your SVI becomes the default gateway for the hosts connected to that Vlan.

in this case, since your router has an ip address that is within the same subnet as the SVI, it makes sense to connect the router to the same Vlan and your pinging will work. For other Vlans to be able to reach the router, you should , as Terry suggested, enable IP routing. Creating SVI's would require routing, either use router-on-a-stick or simply enable routing by typing "ip routing" from global configuratoin mode.

Hope that helps.

Let us know how it goes

CreatePlease to create content
Content for Community-Ad