cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2173
Views
0
Helpful
3
Replies

Cisco 1760 "boot: cannot load flash"

aterscorpio_10
Beginner
Beginner

Hello,

I have two Cisco 1760 routers, and one of them cannot boot from flash correctly. The router defaults to "rommon > 1 " and it displays boot: cannot load flash". I've been searching on the cisco.com site for ways to load the IOS image back into flash, but no luck so far. I tried the tftpdnld command but I believe I might've done something incorrectly becuase it didnt work. I'm getting my feet wet with Cisco and I'd like to be able to load the IOS image back onto this router. Any advise would be greatly appreciated. Could I download the IOS image from my working 1760 and upload it on the non-working router?

thanks,

1 Accepted Solution

Accepted Solutions

If you have the same IOS on both the routers then the image name has to be same. If not, you can run different images on the router without any problem. If you want the consistent featursets across your all the serive routers, I would suggest to have the same IOS on all the routers.

-amit singh

View solution in original post

3 Replies 3

zubairjalal
Beginner
Beginner

hi

have you tried using xmodem

syntax will be

rommon> xmodem -c

After getting some prompts, it will wait for the file to be sent. You should use hyperterminal. There you will find an option of Send Files.Select the protocol as XMODEM and browse to the IOS image on your PC/Laptop. This should do the works for you

Pls rate if useful

regards

Zubair

Thanks Zubair for the reply...I actually went about it a different way. I downloaded the IOS image from my second 1760 using hyperterminal and I put it in a TFTP server. After reading the ROM Monitor handout back and forth a couple of times, I tried the disaster recovery method once again, and this time it worked for me. The question I still have is, does it matter that the IOS name is the same on both routers? (this might be a silly question, but this is my first time downloading/uploading IOS images). Everything seems to be working correctly. I was going to try the XMODEM alternative if the disaster recovery didnt work again.

If you have the same IOS on both the routers then the image name has to be same. If not, you can run different images on the router without any problem. If you want the consistent featursets across your all the serive routers, I would suggest to have the same IOS on all the routers.

-amit singh

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers