cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
909
Views
0
Helpful
8
Replies
Highlighted
Beginner

Cisco 4500-X VSS and issue with speed between server and port-channel links

Hi team , 

Please  i need your help with this issue:

I have 4500 x in vss . All phisical links and all logical port-channels are the same i mean all enable jumbo frames :

interface TenGigabitEthernet1/1/6
switchport access vlan 712
switchport mode access
mtu 9170
channel-group 7 mode active
end

But when i start move my virtual machine between chassis (bare metal servers) the bandwidth  is no more then 2Gbps at the port-channel link.

Jumbo frames are enable from both sides: from 4500 vss and from Hyper-V cloud.

I have seen one more moment : there is service-policy at the VSS and this policy is default for VLS links :

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/15-1-2/XE_340/configuration/guide/config/vss.html 

CS.4500-1#sh int po10 etherchannel
Age of the Port-channel = 25d:22h:41m:46s
Logical slot/port = 21/10 Number of ports = 4
GC = 0x00000000
Port state = Port-channel Ag-Inuse
Protocol = -
Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Te1/1/29 On 0
1 00 Te1/1/30 On 0
2 00 Te1/1/31 On 0
3 00 Te1/1/32 On 0

Time since last port bundled: 25d:22h:41m:18s Te1/1/32

CS.4500-1#sh run int Te1/1/29
Building configuration...

Current configuration : 192 bytes
!
interface TenGigabitEthernet1/1/29
switchport mode trunk
switchport nonegotiate
no lldp transmit
no lldp receive
channel-group 10 mode on
service-policy output VSL-Queuing-Policy
end

And i can't change noting of this:

policy-map VSL-Queuing-Policy
class VSL-MGMT-PACKETS
bandwidth percent 5
class VSL-L2-CONTROL-PACKETS
bandwidth percent 5
class VSL-L3-CONTROL-PACKETS
bandwidth percent 5
class VSL-VOICE-VIDEO-TRAFFIC
bandwidth percent 30
class VSL-SIGNALING-NETWORK-MGMT
bandwidth percent 10
class VSL-MULTIMEDIA-TRAFFIC
bandwidth percent 20
class VSL-DATA-PACKETS
bandwidth percent 20
class class-default
bandwidth percent 5

And at the final i  am not sure but i think the problem here :

Class-map: VSL-DATA-PACKETS (match-any)
102583344 packets
Match: any
Queueing
queue limit 1784 packets
(queue depth/total drops) 0/0
(bytes output) 90124300
bandwidth 20% (2000000 kbps)

Thank you!

8 REPLIES 8
Highlighted
Hall of Fame Expert

Hi,

These are all default parameters added to the VSL links.  You don't need to changes these as there should not be much traffic going over the VSL links anyway.

Does show interface 1/1/6 shows that jumbo is configured?

Have you tried configuring the vm to switch Portchannel as on?

Are the vm interface configured for high availability?

HTH

Highlighted

Hi Reza,

Yes sure.

CS.4500-1#sh int te1/1/6
TenGigabitEthernet1/1/6 is up, line protocol is up (connected)
Hardware is Ten Gigabit Ethernet Port, address is 0081.c413.a905 (bia 0081.c413.a905)
MTU 9170 bytes, BW 10000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)

At one of the port-channel: there is a server and 2 interfaces of which in TEAM. All configuration for jumbo frames are enable. But there is the same issue.

Highlighted

Thanks for the info.

For testing, you may want to use only one interface (no Portchannel) to make sure the interface is working properly.  If these are 10Gig interfaces you should have enough bandwidth to test with.  Also, make sure the server side is configured correctly.

HTH

Highlighted

Today i have made all i need testing: disable port-channel , shut one interface from channel-group but the result is the same - i can't make more then 2Gbps.  It looks like very very strange.

Team how do you think - is it possible to make changes at this default service policy ?

policy-map VSL-Queuing-Policy
class VSL-MGMT-PACKETS
bandwidth percent 5
class VSL-L2-CONTROL-PACKETS
bandwidth percent 5
class VSL-L3-CONTROL-PACKETS
bandwidth percent 5
class VSL-VOICE-VIDEO-TRAFFIC
bandwidth percent 30
class VSL-SIGNALING-NETWORK-MGMT
bandwidth percent 10
class VSL-MULTIMEDIA-TRAFFIC
bandwidth percent 20
class VSL-DATA-PACKETS
bandwidth percent 20
class class-default
bandwidth percent 5

Highlighted

Did you find any solution? I have almost same issue, in VSS with 2 4500x units somehow my uplink upload speed is limited (50-60 Mbits/s on 1G link), if i connect same link to another 4500x without vss its not limited (700 Mbits/s on same 1G link). I'm totally confused with this...


Abdullo Salikhov
Dushanbe, Tajikistan
Highlighted

50 - 60 Mbits is 5% of 1G link and I assume it is getting limited due to:

class class-default
bandwidth percent 5

 

Can anyone help ?


Abdullo Salikhov
Dushanbe, Tajikistan
Highlighted

Hi there.  I was wondering if you ever found the cause of the bandwidth limitation you were seeing on your 4500's. I am having the exact same issue.  Was it related to the VSL queuing policy?

Highlighted

Hello.

 

It was a bug in software, go ahead and update your software on devices and it should be solved. Check your CPU stats


Abdullo Salikhov
Dushanbe, Tajikistan
Content for Community-Ad