cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
595
Views
5
Helpful
9
Replies

Dedicate Bandwidth-QoS

Anukalp S
Level 1
Level 1

Hello.. i have been running two Nexus 9396 release 6.x Both N9K(N9K-1& N9K-2) are connected with VPC-peer link. These are located and running  in Site-A. We have also been running a catalyst 3850 on Site-B.

We have one P2P connectivity b/w these two locations. One end of P2P circuit is terminated on N9K-2 and other end on 3850.  Circuit bandwidth is 50Mbps.

We want to reserve/dedicate  10Mb bandwidth for VOIP traffic and rest bandwidth for others traffic.

Please help me to configure QoS for it.

1 Accepted Solution

Accepted Solutions

Exactly, you need to apply the policy only on the link to Site B, so nothing is required on N9K-1.

View solution in original post

9 Replies 9

Hello,

 

something like the below should work:

 

Nexus

 

class-map type qos match-any VoIP_Class
match dscp cs6
!
policy-map type qos VoIP_Policy
class VoIP_Class
bandwidth percent 20
class class-default
!
interface port-channel 1
service-policy type qos input VoIP_Policy

 

3850

 

class-map match-any VoIP_Class
match dscp cs6
!
policy-map VoIP_Policy
class VoIP_Class
bandwidth percent 20
class class-default
!
interface port-channel 1
service-policy input VoIP_Policy

Thanks.. but why is it attached as input under port-channel interface.

P2P circuit is connected to switches  L3 interfaces. On Nexus 9K-2 side it is connected on port E1/32(192.168.20.5) and on 3850 side it is on Gig 1/0/22(192.168.20.6).

 

Shouldn't policy applied on these L3 interfaces as service-policy output ,  pls help

 

Hello,

 

it is just an example. Indeed, if you have L3 interfaces one each side, apply the policy outbound.

Hello.. i am looking to use below config, please confirm if this will allocate 10Mb bandwidth for voip traffic in case of congestion. also look into below config and suggest if it will work well without any issues.

 

 

------------------------------------------------

ip access-list extended voip
permit ip 192.168.195.0 0.0.0.255 192.168.221.0 0.0.0.255 any


class-map match-any VOIP
match access-group name voip

!
!
policy-map police_voice
class VOIP
priority percent 20
class class-default
bandwidth remaining percent 80
fair-queue
policy-map SHAPE
class class-default
shape average 50000000
service-policy police_voice

 

ip access-list extended voip
permit ip 192.168.195.0 0.0.0.255 192.168.221.0 0.0.0.255 any


int Ethernet1/x
service-policy output SHAPE

Your access list needs to match actual VoIP traffic, typically CS6 and CS3. So add that to your access list:

 

ip access-list extended voip
permit ip 192.168.195.0 0.0.0.255 192.168.221.0 0.0.0.255 any dscp cs3
permit ip 192.168.195.0 0.0.0.255 192.168.221.0 0.0.0.255 any dscp cs6

Thanks for the suggestion, rest configuration is fine, please confirm.

Hello,

 

you don't need a parent/child policy. The below should be sufficient:

 

ip access-list extended voip
permit ip 192.168.195.0 0.0.0.255 192.168.221.0 0.0.0.255 any eq cs3
permit ip 192.168.195.0 0.0.0.255 192.168.221.0 0.0.0.255 any eq cs6
!
class-map match-any VOIP
match access-group name voip
!
policy-map police_voice
class VOIP
priority percent 20
class class-default
fair-queue
shape average 50000000

!

int Ethernet1/x
service-policy output police_voice

Thanks.. one more concern since all traffic to site B is routing from N9K-2 even traffic originating from N9K-1 is moving first to N9K-2 and then towards site-B. In this case this policy is not required on N9K-1.

Please correct me if i am wrong.

 

 

 

 

Exactly, you need to apply the policy only on the link to Site B, so nothing is required on N9K-1.

Review Cisco Networking products for a $25 gift card