08-03-2015 06:00 AM - edited 03-08-2019 01:13 AM
Hello
I am trying the setup a Cisco 2801 router behind my Comcast router. I do not want to put the Comcast device in bridge mode, I want to use the wireless from it. I am not sure what I am doing wrong. This setup worked fine when I was using an old Linksys router in place of the 2801 router.
interface FastEthernet0/0
description UPLINK TO COMCAST ROUTER
ip address dhcp
ip nat outside
ip virtual-reassembly
speed auto
full-duplex
!
interface FastEthernet0/1
description LAN SEGMENT
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
full-duplex
!
interface Serial0/1/0
no ip address
shutdown
!
interface Serial0/2/0
no ip address
shutdown
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip nat source list 50 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.1.150 80 interface FastEthernet0/0 80
!
access-list 50 permit 192.168.1.0 0.0.0.255
!
RTR_2801#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms
RTR_2801#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
RTR_2801#ping 192.168.1.111
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.111, timeout is 2 seconds:
!!!!!
PC info
IP Addresss 192.168.1.111
Subnet Address 255.255.255.0
Default Gateway 192.168.1.1
DNS 192.168.1.1
DNS 75.75.75.75
This is for a lab environment, so when I mess up the wireless still works in the rest of the house. I have a webserver at 192.168.1.150 that worked without any issue using the old Linksys and double NAT
Thanks in advance
Solved! Go to Solution.
08-04-2015 10:52 AM
Change "ip default-gateway 192.168.1.1"
to "ip default-gateway 10.0.0.1" (point towards your Comcast router ... guessing 10.0.0.1)
Change "ip nat source list 50 interface FastEthernet0/0 overload"
to "ip nat inside source list 50 interface FastEthernet0/0 overload"
Make sure that "ip routing" is enabled (your post doesn't include that config section)
See if that helps.
08-04-2015 10:52 AM
Change "ip default-gateway 192.168.1.1"
to "ip default-gateway 10.0.0.1" (point towards your Comcast router ... guessing 10.0.0.1)
Change "ip nat source list 50 interface FastEthernet0/0 overload"
to "ip nat inside source list 50 interface FastEthernet0/0 overload"
Make sure that "ip routing" is enabled (your post doesn't include that config section)
See if that helps.
08-04-2015 11:43 AM
Thank you for your response, I will try it tonight and let you know.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide