cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
686
Views
0
Helpful
3
Replies
hamzashahid
Beginner

Ether-channel problem between two different vendors

hi this is hamza 

i m making ether-channel between two different switches first one is Cisco catalyst 3560 24PS and on other side fortiswitch 14D i have plugged two backbones on port 21 and 22 on Cisco side and on port 1 and 24 on fortiswitch side 

fortiswitch is using active mode while cisco is using passive mode 

 

as u can see the configuration 

 

the problem is when i configure ether-channel cisco switch shutdown port fa0/21 and if i plug into on another port it gets back up, it seems when i make-up LACP protocol that backbone doesn't work

both sides have same duplex and speed and both backbones are same in every form

 

Current configuration : 1739 bytes
!
version 12.2
service config
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Switch
!
enable secret 5 $1$3E0V$UTj9qgb9OFltI28QZpi1p0
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no keepalive
speed 100
duplex full
channel-group 1 mode passive
channel-protocol lacp
!
interface FastEthernet0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
speed 100
duplex full
channel-group 1 mode passive
!
interface FastEthernet0/23
speed 100
duplex full
!
interface FastEthernet0/24
speed 100
duplex full
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address dhcp
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
password 7 045A0F0B062F6C1C584B
login
line vty 5 15
password 7 045A0F0B062F6C1C584B
login
!
end

 

i tried without switchport nonegotiate but that still doesn't work out

 

hope u understand that problem 

 

Best Regards:

HAMZA SHAHID

1 ACCEPTED SOLUTION

Accepted Solutions

The switchport trunk encapsulation dot1Q command is an older command for older IOS because in the past Cisco devices supported both ISL and dot1q. If you are running a new version of IOS, you don't need this command. All you need is:

switchport mode trunk

HTH

View solution in original post

3 REPLIES 3
Reza Sharifi
Hall of Fame Expert

Hi,

If LACP does not work try it mode on.Example:

interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
speed 100
duplex full
channel-group 1 mode on

And test again.

HTH

yes i will try this one , but i did not understand why do we need to use switchport trunk encapsulation dot1Q instead only using switchport mode trunk  i never use this encapsulation in packet tracer if this is necessary to use it with switchport mode trunk then y did not Cisco recommend it while training of CCNA

 

can u please guide me that switches in packet tracer performing layer 3 switches or layer 2 i can olny understand of word between L3 and L2 is the difference of ip assigning is it true or their is something else 

 

Best Regards:

HAMZA SHAHID 

 

The switchport trunk encapsulation dot1Q command is an older command for older IOS because in the past Cisco devices supported both ISL and dot1q. If you are running a new version of IOS, you don't need this command. All you need is:

switchport mode trunk

HTH

View solution in original post