cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1771
Views
10
Helpful
13
Replies

Etherchannel connectivity issue between C9300 stack switch and VMWare ESXi 6.7 host

Breejesh
Beginner
Beginner

Hello Experts,

 

I am currently facing an issue with etherchannel loosing connectivity with VMWare ESXi 6.7 host server. This is the new setup.

So I have got 2 C9300 series switches (C9300-48UXM-A and C9300-48P-A) stack together. And 2 gig ports from C9300-48P-A are part of etherchannel connecting to VMWare ESXi host.

 

Problem :- I loose the connectivity to the server every now and then. I need to shut and no shut one of the member ports in the channel to restore the connectivity but connectivity last only for couple of minutes.

I neither see any related error in logs nor seeing port going in err-disable mode. port-channel and both the ports status shows UP at the time I loose the connectivity. Below is the configuration on the switch stack. I have also attached output of "show version" command and interfaces status from the time I lost the connectivity to the server.

Please advise as to what I am missing here.

 

interface Port-channel1

switchport trunk native vlan 999

switchport trunk allowed vlan 20,50,199

switchport mode trunk

spanning-tree portfast trunk

end

 

 

interface GigabitEthernet2/0/38

switchport trunk native vlan 999

switchport trunk allowed vlan 20,50,199

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast trunk

end

 

 

interface GigabitEthernet2/0/45

switchport trunk native vlan 999

switchport trunk allowed vlan 20,50,199

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast trunk

end

13 Replies 13

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

Post the complete output to the following commands: 

sh controller e Gi2/0/38
sh controller e Gi2/0/45
sh platform pm interface-flaps Gi2/0/38 | b LinkNeg
sh platform pm interface-flaps Gi2/0/45 | b LinkNeg

Hello

 

Please find attached output of said commands. Thanks

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

I've reviewed the output.  

There is nothing wrong with the links -- not a Layer 1 issue. 

I'm going to say that the issue is at the VM side.

Hello

 

I will re-visit ESXi side configuration for any correction. Thank you for reviewing the output.

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

             - Check (networking related)  logs on ESX too , to possibly get further insights.

 M.

omz
Collaborator
Collaborator

Check the port-channel config and hashing algorithm on VMware

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

The interfaces have:

 492 unknown protocol drops

 So, can you make sure that the ESXi site is configured the same as the switch (mode on)?

If that does not help, try using both interfaces without any Portchannel configuration. Sometimes VMs and Portchannels don't play well together.

HTH

Hello

 

I do not see any specific option to enable/disable "mode on" in ESXi host but port-channel/interfaces don't come up if I set the mode to either active (LACP) or auto (PAgP) on stack switch. I have attached the screenshot of ESXi Nic teaming configuration which was configured following the VMWare official document.

 

Regarding unknown protocol drops, I have read one of the discussion in Cisco community that these drops occurs when the interfaces in port-channel, are configured with trunk and that such errors can be ignored. Correct me if that understand is wrong.

 

Can this be an issue of the code version on the stack switch? Or port-channel connectivity with ESXi host on the stack switches doesn't work well?

 

BTW, I configured both interfaces without port-channel and the connectivity got restored. But is this a best practice to have dual port connectivity with ESXi host without port-channel? And will I get failover/load balancing capabilities?

 

Just for information, I have same NIC teaming on ESXi and port-channel/interfaces configuration on C2960 stack switch for other location and it is working just fine.

Hi,

BTW, I configured both interfaces without port-channel and the connectivity got restored. But is this a best practice to have dual port connectivity with ESXi host without port-channel? And will I get failover/load balancing capabilities?

Yes, as long as the NIC teaming/failover is set up correctly on the ESXi hosts, the failover from one interface to other will work just fine. We have Dell servers with ESXi hosts configured this way and when we test by shutting down one of the interfaces on the server or the switch, the failover works just fine.

 

HTH

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

Disable DTP (switchport nonegotiate)  on the PC trunk that should deal with the unknown protocol drops.

Does the server support LACP is so try using it instead of a static PC.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello

 

DTP is already disable. I am not seeing any option in ESXi to enable LACP on server but when I enable it on switch side, port-channel doesn't come UP and in the logs, I can see the error stating "LACP is not supported on remote port". So, I guess, LACP is not supported on server.

MHM Cisco World
Advisor
Advisor

Hello

 

I have followed thew same article to create the vSwitch and build the NIC teaming on server.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: