cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
565
Views
0
Helpful
1
Replies
Ahmed M Alzaeem
Beginner

help in operating csico 7604 with squid server with wccp protocol !

hi ,

i have the topology :

Image

=============================================
want to mention that im using port address translation on the router & not sure if it is making a conflict .

hereis the config below :

why the  cache is not working ??

i mean that i tried going to internet with source ips of the subnet 10.20.30 , but i seems went to internet without any precedence of cahce server .

i just want to troubleshoot and estimate of this problem from cahce or from router config

=====================================================================

""i removed the unnecessary outputs""
Gateway7600#sh run

ip wccp 80 redirect-list CACHE80
ip wccp 90 redirect-list CACHE90



!

spanning-tree mode pvst
spanning-tree extend system-id
system flowcontrol bus auto


vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!        

!
interface GigabitEthernet1/1
description lan
ip address 10.160.150.3 255.255.255.0
ip nat inside
ip wccp 80 redirect in
load-interval 30
!        

!
interface GigabitEthernet1/3
ip address 192.168.250.1 255.255.255.252
ip wccp redirect exclude in
!
interface GigabitEthernet1/4
no ip address
shutdown
!
interface GigabitEthernet1/5
no ip address
shutdown
!
interface GigabitEthernet1/6
no ip address
shutdown
!
interface GigabitEthernet1/7
no ip address
shutdown
!
interface GigabitEthernet1/8
no ip address
shutdown
!
interface GigabitEthernet1/9
description  internet
ip address x.x.45.1 255.255.255.252
no ip redirects
ip nat outside
ip wccp 90 redirect in
load-interval 30
!
interface GigabitEthernet1/9.1
encapsulation dot1Q 2
!
interface Vlan1
no ip address
!

ip nat inside source list nat interface GigabitEthernet1/9 overload
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 b.b.b.b
ip route xxxxx xxxxxxx
ip route xxxxx xxxxxxx
ip route xxxxx xxxxxxx
ip route xxxxx xxxxxxx
ip route xxxxx xxxxxxx
!
ip access-list extended CACHE80
permit tcp host 10.20.30.50 any eq www
permit tcp host z.z.z.z any eq www
ip access-list extended CACHE90
permit tcp any host 10.20.30.50
permit tcp any host z.z.z.107
ip access-list extended nat
permit ip 10.20.30.0 0.0.0.255 any


end

regards

1 REPLY 1
jhiggins
Beginner

per http://www.cisco.com/en/US/docs/ios-xml/ios/ipapp/configuration/12-4/iap-wccp.html

pdf page 27

interface GigabitEthernet1/3

ip address 192.168.250.1 255.255.255.252

ip wccp redirect exclude in

ip nat inside