cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
721
Views
0
Helpful
6
Replies

Hosts on Configured VLAN can't ping between Cisco Catalyst 2960s switch and GarrettCom Maknum 10KT switch

rafik_rez
Level 1
Level 1

Dear Cisco Forumers,

I have the following archtitecture:

- PCa (IP 172.17.200.191) is connected to port 21 of CiscoSwitch, this port belongs to VLAN 11.

- CiscoSwitch is connected via its port 23 (trunk) to port 6 of GarrettSwitch, which is tagged with VLAN 11.

- PCb (IP 172.17.200.193) is plugged to GarrettSwitch on port 5, which default VLAN is VLAN 11.

- CiscoSwitch is a Cisco Catalyst 2960S switch, and GarrettSwitch is a GarrettCom Magnum 10KT switch.

When I try to ping PCa from PCb it fails, and the other way around too. 

But when I ping PCs belonging to VLAN 11 in CiscoSwitch it works.

Also when I ping PCs belonging to VLAN 11 in GarrettSwitch it works.

Also when I piung PCs belonging to default VLAN1 from GarrettSwitch to CiscoSwitch it works.

Do you have any idea of how I can make VLAN 11 on CiscoSwitch talk to VLAN 11 on GarrettSwitch talk to each other?

6 Replies 6

rafik_rez
Level 1
Level 1

Below is the configuration of the CiscoSwitch:

CiscoSwitch#show running-config
Building configuration...
Current configuration : 4142 bytes
!
version 12.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
!
hostname CiscoSwitch
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 xxxxxxxxxxxxxxxxxxxxx.
!
username admin secret 5 xxxxxxxxxxxxxxxxxxxxxxxxx
!
!
no aaa new-model
switch 1 provision ws-c2960s-24ts-l
!
!
ip domain-name xxxxxx.local
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 28672
!
!
!
!
vlan internal allocation policy ascending
!
ip ssh authentication-retries 5
ip ssh source-interface Vlan1
ip ssh logging events
ip ssh version 2
!
!
interface Loopback1
no ip address
!
interface FastEthernet0
no ip address
shutdown
!
interface GigabitEthernet1/0/1
description xxxxxxxxxx
switchport access vlan 11
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/2
description xxxxxxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/3
description xxxxxxxxxxxxxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/4
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/5
description xxxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/6
description xxxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/7
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/8
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/9
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/10
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/11
description xxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/12
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/13
description xxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/14
description xxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/15
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/16
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/17
description xxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/18
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/19
description xxxx
!
interface GigabitEthernet1/0/20
description xxxx
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/21
description xxxx
switchport access vlan 11
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/22
description xxxxx
switchport mode trunk
!
interface GigabitEthernet1/0/23
description xxxxx
switchport mode trunk
!
interface GigabitEthernet1/0/24
description xxxx
switchport mode trunk
!
interface GigabitEthernet1/0/25
description SHUTDOWN
switchport mode access
shutdown
!
interface GigabitEthernet1/0/26
description SHUTDOWN
switchport mode access
shutdown
!
interface GigabitEthernet1/0/27
description SHUTDOWN
switchport mode access
shutdown
!
interface GigabitEthernet1/0/28
description SHUTDOWN
switchport mode access
shutdown
!
interface Vlan1
ip address 172.17.200.12 255.255.255.0
!
ip default-gateway 172.17.200.1
no ip http server
no ip http secure-server
snmp-server community Yknms01 RO
!
line con 0
session-timeout 90
exec-timeout 60 0
login local
line vty 0 4
session-timeout 90
exec-timeout 60 0
login local
transport input ssh
transport output all
line vty 5 15
session-timeout 90
exec-timeout 60 0
login local
transport input ssh
transport output all
!
end
CiscoSwitch#

And below is the configuration of the GarrettCom switch:

Magnum 10KT#show config run
#!META 46 102 99 0 0
#System Manager#
set bootmode type=manual
ipconfig ip=172.17.200.24 mask=255.255.255.0 dgw=172.17.200.1
access
exit
#User Management#
user
add user=admin level=2 pass=password
enable admin pass=password
user
delete user=manager
delete user=operator
exit
#Access#
#HOSTS#
access
gdp disable
gdp proxy status=disable
exit
#Alarm Config#
alarm
exit
#Port Management#
device
setport port=5 name=C1_xxxx flow=disable bp=disable auto=enable status=enable
setport port=6 name=C2_xxxx flow=disable bp=disable auto=enable status=en able
setport port=13 name=E1_xxx flow=disable bp=disable duplex=full status=enable
setport port=14 name=E2_xxxx flow=disable bp=disable duplex=full status=enable
setport port=15 name=E3_xxxx flow=disable bp=disable duplex=full status=enable
setport port=16 name=E4 flow=disable bp=disable duplex=full status=disable
#Broadcast Multicast Protection#
exit
#QOS#
qos
set-weight weight=1
exit
#Flow Control#
device
exit
device
exit
#STP#
set stp type=stp
stp
exit
#RSTP#
set stp type=rstp
rstp
rstp enable
exit
set stp type=rstp
#Port Security#
port-security
exit
#Port Security Mac#
port-security
exit
#SNTP#
set timezone GMT=+ hour=1 min=0
sntp
exit
#VLANS#
set vlan type=tag
vlan type=none
exit
vlan type=tag
add id=11 name="VLAN11" port=5-7,13-15
start vlan=11
set-port tagging id=11 port=6 status=tagged
set-port port=5 default id=11
set-port port=7 default id=11
set-port port=13 default id=11
set-port port=14 default id=11
set-port port=15 default id=11
exit
#GVRP#
gvrp
exit
#SNMP#
set snmp type=all
snmpv3
setvar sysname="GarrettSwitch" syscontact="support@garrettcom.com" syslocation="W-TC-001"
view add id=1 viewname=all type=included subtree=.1 mask=ff
exit
set snmp type=v1
snmp
authentraps disable
exit
set snmp type=v1
rmon
exit
#SMTP#
smtp
exit
#IGMP#
igmp
mcast enable
exit
#LACP#
lacp
exit
#LLDP#
lldp
exit
#PTP#
ptp
ptp disable
exit
Magnum 10KT#

Without knowing anything about the Garret switch, I would suspect that the native vlan on the Cisco switch is 1, and on the Garret switch port 6 is VLAN 11.  Are there messages in either switch to indicate a fault?

On Cisco port 23, try

switchport trunk encap dot1q

switchport trunk native vlan 11

Hi pwwiddicombe! 

Thanks for answering.

I will try the switchport trunk native vlan 11 on port 23 tomorrow and keep the topic updated.

I've already tried switchport trunk encap dot1q, and it didn't work, apparently Cisco Switch Catalyst 2960-S enables only one encapsulation mode. Still was not successfull in knowing which one was it.

When I do a show interfaces gi1/0/23, I get the following, which apparently indicates that the Encapsulation used is ARPA. Is it the way to know the encapsulation mode?

CiscoSwitch#show interfaces gi1/0/23
GigabitEthernet1/0/23 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is c40a.cb47.bd97 (bia c40a.cb47.bd97)
Description: xxxxx
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 4000 bits/sec, 7 packets/sec
4722 packets input, 349741 bytes, 0 no buffer
Received 2698 broadcasts (53 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 53 multicast, 0 pause input
0 input packets with dribble condition detected
3523374 packets output, 241995368 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

sh int gi 1/0/23 trunk

I tried switchport trunk encap dot1q on the cisco port 23, and ended up with same result.

I did show interfaces switchport and I got the following for Gi1/0/23:

Name: Gi1/0/23
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled


					
				
			
			
				
			
			
				
			
			
			
			
			
			
		
Review Cisco Networking products for a $25 gift card