cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14093
Views
0
Helpful
6
Replies

How do I configure a router/switch act as an ISP?

sabregod
Level 1
Level 1

Hi all,

I'm building a network that happens to be: PC -> R1 -> R2 -> R3 -> ISP. The R3 will be configured as DHCP Server and I'll practice NAT/PAT on it too. My question is how do I make the ISP act as a router or switch?

Thanks in advance

1 Accepted Solution

Accepted Solutions

Here we go, I detected that R3 and ISP were not able to make ping each other, it could be because the network 1.0.0.0, I never used that but aparently it was not supported. I changed them to network 10.0.0.0

Please see my config, on R3 and ISP, i have created a nat pool to emulate a public IP, also debug ip nat is supported, please verify it once the ping is execute on the PC.

If you dont want the pool, you can remove and replace the NAT statement by the following:

ip nat inside source list PRIVATE-NETS interface FastEthernet0/0 overload

Please remember to rate the comment if it is useful or answered the question. 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

6 Replies 6

Julio E. Moisa
VIP Alumni
VIP Alumni

Hi

As it is a Lab, you could configure specifics static routes on ISP router to have reachability to all the networks in R1, R2 and R3 and create loopbacks to simulate public networks, for example 

interface loopback 100
description Internet
ip address 8.8.8.8 255.255.255.255 
ip address 100.100.100.100  255.255.255.255 secondary

Remember the ISP router knows how to return the packets, that is the reason of the static routes pointing to R3. In order to verify the NAT you could use a debug: debug ip nat translations   on R3. To disable the debug, you can use: undebug all or u all

Now R3 should have a default route pointing to ISP router.

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Thanks. I set the static route of ISP to reach all networks but I can also ping the loopback which I shouldn't have to since I haven't configured NAT? I should've mention I'm doing it in packet tracer :)

You are right, 

Try this config on the R3 router, 

int g0/0
description TO-ISP-ROUTER
Ip address 10.0.0.1 255.255.255.252
ip nat outside
no shutdown

int g0/1
description TO-R2
ip add 192.168.1.1 255.255.255.0
ip nat inside
no shutdown

ip access-list standard PRIVATE-NETS
permit ip 172.16.10.0 0.0.0.255
permit ip 172.16.11.0 0.0.0.255
permit ip 172.16.12.0 0.0.0.255
<basically the subnets to be translated to the public IP>

interface G0/2
description PUBLIC-IP-PROVIDED-BY-ISP
ip add 190.1.1.1 255.255.255.252
no keepalive   <-- it will keep UP UP the interface although it is not connected to any device. 

ip nat inside source list PRIVATE-NETS interface g0/2 overload

ip route 0.0.0.0 0.0.0.0 10.0.0.2 name TO-INTERNET  (ISP Router)

Unfortunately on packet tracer we cannot use loopback for NAT (I used g0/2 an available interface) but try the config above or try just removing the statics routes on IPS Router and try again. If is possible please share your config on R3 and ISP thanks

ISP ROUTER

Please remove all the static routes created previously and just create one.

ip route 190.1.1.1 255.255.255.255 10.0.0.1 

Remember activate the debug on R3.

Please keep me posted. not sure if debug can be executed on packet tracer. 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Please feel free to share the config in order to verify.

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Here's my packet tracer which includes all configuration so far.

Here we go, I detected that R3 and ISP were not able to make ping each other, it could be because the network 1.0.0.0, I never used that but aparently it was not supported. I changed them to network 10.0.0.0

Please see my config, on R3 and ISP, i have created a nat pool to emulate a public IP, also debug ip nat is supported, please verify it once the ping is execute on the PC.

If you dont want the pool, you can remove and replace the NAT statement by the following:

ip nat inside source list PRIVATE-NETS interface FastEthernet0/0 overload

Please remember to rate the comment if it is useful or answered the question. 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<