10-10-2017 11:41 PM - edited 03-08-2019 12:19 PM
Hi Experts, Could you please suggest if this is a valid ACL statement.
I want to restrict access from vlan20(172.20.2.0/24 Network) to other vlan. Also need to permit access to my WAN Devices which is of ip address, 172.20.4.2,172.20.4.4 and 172.20.4.5. Please suggest.
If this needs an correction, kindly help.
access-list 199 permit any 172.20.4.0 0.0.0.6 – Access to WAN Gateway
access-list 199 deny any any – Restricting access to other vlan
interface Vlan20
description XYZ Network
ip address 172.20.2.1 255.255.255.0
ip helper address 172.20.2.1
ip access-group 199 in
Solved! Go to Solution.
10-11-2017 03:36 AM
Prob betfter putting it both directions so i have altered the acl so there is a reverse rule to so can go in/out
ip access-list extended test
permit ip host 172.20.4.2 172.20.2.0 0.0.0.255
permit ip host 172.20.4.4 172.20.2.0 0.0.0.255
permit ip host 172.20.4.5 172.20.2.0 0.0.0.255
permit ip 172.20.2.0 0.0.0.255 host 172.20.4.2
permit ip 172.20.2.0 0.0.0.255 host 172.20.4.4
permit ip 172.20.2.0 0.0.0.255 host 172.20.4.5
deny ip any 172.20.2.0 0.0.0.255
deny ip 172.20.2.0 0.0.0.255 any
permit ip any any
interface Vlan20
description XYZ Network
ip address 172.20.2.1 255.255.255.0
ip access-group test in
ip access-group test out
10-11-2017 12:25 AM - edited 10-11-2017 12:26 AM
Hi
if i understood that correctly allow the wan devices speak to vlan 20 but vlan 20 then blocked from speaking to erveryone else , if the wan devices are just to speak to the host ip you can alter it , apply it in and outbound under the interface
ip access-list extended test
permit ip host 172.20.4.2 172.20.2.0 0.0.0.255
permit ip host 172.20.4.4 172.20.2.0 0.0.0.255
permit ip host 172.20.4.5 172.20.2.0 0.0.0.255
deny ip 172.20.2.0 0.0.0.255 any
permit ip any any
By the way your helper address shouldnt be the vlan interface , it should be the dhcp server address and if the dhcp scop is on the device then you dont need the helper
interface Vlan20
description XYZ Network
ip address 172.20.2.1 255.255.255.0
ip helper address 172.20.2.1
10-11-2017 01:00 AM
10-11-2017 01:14 AM
10-11-2017 02:52 AM
10-11-2017 03:36 AM
Prob betfter putting it both directions so i have altered the acl so there is a reverse rule to so can go in/out
ip access-list extended test
permit ip host 172.20.4.2 172.20.2.0 0.0.0.255
permit ip host 172.20.4.4 172.20.2.0 0.0.0.255
permit ip host 172.20.4.5 172.20.2.0 0.0.0.255
permit ip 172.20.2.0 0.0.0.255 host 172.20.4.2
permit ip 172.20.2.0 0.0.0.255 host 172.20.4.4
permit ip 172.20.2.0 0.0.0.255 host 172.20.4.5
deny ip any 172.20.2.0 0.0.0.255
deny ip 172.20.2.0 0.0.0.255 any
permit ip any any
interface Vlan20
description XYZ Network
ip address 172.20.2.1 255.255.255.0
ip access-group test in
ip access-group test out
10-11-2017 03:38 AM
10-11-2017 12:26 AM
10-11-2017 11:48 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide