10-01-2016 02:30 PM - edited 03-08-2019 07:38 AM
I have configured 2 Multilayer switches (in two buildings) connected to a router. I have configured VLAN, NAT, access-list and default route. I am able to ping internet and the router and the internet (Default Route), but I cannot ping the other layer switch in other building. I tried to configure EIGRP on the switches and the router, but I am still unable to ping the computers in the other building. When I configured the EIGRP I did not get any discovery message!
I have attached an image of my topology I am using. I basically have 1 router connected to both switches and internet. Switches are in separate buildings and have VLANs, NAT, default route configured.
Solved! Go to Solution.
10-01-2016 07:29 PM
Hi,
The reason EIGRP is not peering betwwen the router and the switches is that you:
You don't have common IP subnet between the switches and the router. You switch is configured with all 10.100.x.x subnets but the router does not have any interface that has any 10.100.x.x subnet.
First, figure out what interface/vlan is connecting the switches to the router.
Than configure one IP an each side in the same subnet.
example:
router
interface gi0/0 (assuming this is the interface that connects one of the switches to the router)
ip address 10.100.100.1 255.255.255.252
router eigrp 1
network 10.100.100.0 255.255.255.0
switch
interface gix/x (this is the interface that connects to the router)
no switchport
ip address ip address 10.100.100.2 255.255.255.252
router eigrp 1
network 10.100.100.0 255.255.255.0
now ping from the switch to the router and vice versa to make sure connectivity is good.
If ping is good you should see eigrp peering between the switch and the router.
HTH
10-01-2016 05:38 PM
Do you have EIGRP peering between each switch and the router?
"sh ip eigrp neigh" will show you that.
Can you post "sh run" from all 3 devices?
Also, you need a connection between the 2 switches in 2 different buildings.
HTH
10-01-2016 07:09 PM
Hello,
Thanks for reply. The result of sh ip eigrp neigh shows the following:
Switch1 building a
sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
Switch 2 building b
sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
Router:
sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
The result of show running-config is:
Switch 1 building a:
ip dhcp pool POOL-1
network 10.100.50.48 255.255.255.240
default-router 10.100.50.50
ip dhcp pool POOL-2
network 10.100.50.80 255.255.255.240
default-router 10.100.50.82
ip dhcp pool POOL-3
network 10.100.50.32 255.255.255.240
default-router 10.100.50.34
ip dhcp pool POOL-4
network 10.100.50.96 255.255.255.240
default-router 10.100.50.98
ip dhcp pool POOL-5
network 10.100.50.16 255.255.255.240
default-router 10.100.50.18
ip dhcp pool POOL-6
network 10.100.50.64 255.255.255.240
default-router 10.100.50.66
!
!
ip routing
interface FastEthernet0/1
switchport access vlan 45
!
interface FastEthernet0/2
switchport access vlan 55
!
interface FastEthernet0/3
switchport access vlan 40
!
interface FastEthernet0/4
switchport access vlan 60
!
interface FastEthernet0/5
switchport access vlan 50
!
interface FastEthernet0/6
switchport access vlan 35
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
no switchport
ip address 18.0.0.1 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
interface Vlan35
ip address 10.100.50.18 255.255.255.240
ip nat inside
!
interface Vlan40
ip address 10.100.50.34 255.255.255.240
ip nat inside
!
interface Vlan45
ip address 10.100.50.50 255.255.255.240
ip nat inside
!
interface Vlan50
ip address 10.100.50.66 255.255.255.240
ip nat inside
!
interface Vlan55
ip address 10.100.50.82 255.255.255.240
ip nat inside
!
interface Vlan60
ip address 10.100.50.98 255.255.255.240
ip nat inside
router eigrp 1
network 10.0.0.0
network 10.100.50.16 0.0.0.15
network 10.100.50.32 0.0.0.15
network 10.100.50.48 0.0.0.15
network 10.100.50.64 0.0.0.15
network 10.100.50.80 0.0.0.15
network 10.100.50.96 0.0.0.15
auto-summary
!
ip nat inside source list 1 interface GigabitEthernet0/2 overload
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/2
!
ip flow-export version 9
!
!
access-list 1 permit 10.100.50.48 0.0.0.15
access-list 1 permit 10.100.50.80 0.0.0.15
access-list 1 permit 10.100.50.32 0.0.0.15
access-list 1 permit 10.100.50.96 0.0.0.15
access-list 1 permit 10.100.50.16 0.0.0.15
access-list 1 permit 10.100.50.64 0.0.0.15
!
Configuration for Switch 2 building b is similar with different VLANs and IP
Router Configuration:
interface GigabitEthernet0/0
ip address 18.0.0.2 255.255.255.252
ip access-group 1 in
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 65.100.1.1 255.255.255.240
ip access-group 1 in
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 195.165.85.2 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 18.0.0.0
network 65.0.0.0
network 18.0.0.0 0.0.0.3
network 65.100.1.0 0.0.0.15
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip classless
!
ip flow-export version 9
!
!
access-list 1 deny 10.100.50.48 0.0.0.15
access-list 1 deny 10.100.50.80 0.0.0.15
access-list 1 deny 10.100.50.32 0.0.0.15
access-list 1 deny 10.100.50.96 0.0.0.15
access-list 1 deny 10.100.50.16 0.0.0.15
access-list 1 deny 10.100.50.64 0.0.0.15
access-list 1 permit any
access-list 1 deny 192.168.85.32 0.0.0.31
access-list 1 deny 192.168.85.64 0.0.0.31
access-list 1 deny 192.168.85.96 0.0.0.31
access-list 1 deny 192.168.85.128 0.0.0.31
access-list 1 deny 192.168.85.160 0.0.0.31
access-list 1 deny 192.168.85.192 0.0.0.31
10-01-2016 07:29 PM
Hi,
The reason EIGRP is not peering betwwen the router and the switches is that you:
You don't have common IP subnet between the switches and the router. You switch is configured with all 10.100.x.x subnets but the router does not have any interface that has any 10.100.x.x subnet.
First, figure out what interface/vlan is connecting the switches to the router.
Than configure one IP an each side in the same subnet.
example:
router
interface gi0/0 (assuming this is the interface that connects one of the switches to the router)
ip address 10.100.100.1 255.255.255.252
router eigrp 1
network 10.100.100.0 255.255.255.0
switch
interface gix/x (this is the interface that connects to the router)
no switchport
ip address ip address 10.100.100.2 255.255.255.252
router eigrp 1
network 10.100.100.0 255.255.255.0
now ping from the switch to the router and vice versa to make sure connectivity is good.
If ping is good you should see eigrp peering between the switch and the router.
HTH
10-01-2016 08:23 PM
This is correct! I get discovery message from router on both switches, but I am still unable to ping computers in building B. I only see routers network when I run sh ip eigrp neighbor
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide