cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
743
Views
10
Helpful
3
Replies
Stuart D
Beginner

Implementing VLANs in a Hierarchical Design

Hello,

I'm fairly new to this, so I apologise if the solution is obvious.

I'm trying to get the two PCs in vlan10(green) to communicate with each other, however I'm not sure how to do this with a third multilayer switch between them. The multilayer switch is on the distribution layer whilst the standard switches are at the access layer. I could get it working with a connection between just the layer 2 switches, but could anyone help me with the multilayer switch between? I've included a screenshot of the topology as well as what I've configured so far below.

help.jpg

 

Switch 1:

interface Port-channel1

switchport mode trunk

!

interface FastEthernet0/1

switchport mode trunk

channel-group 1 mode active

!

interface FastEthernet0/2

switchport mode trunk

channel-group 1 mode active

!

interface FastEthernet0/10

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 20

switchport mode access

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

mac-address 0001.97c3.a001

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

mac-address 0001.97c3.a002

ip address 192.168.20.1 255.255.255.0

!

 

Switch 2:

interface Port-channel2

switchport mode trunk

!

interface FastEthernet0/1

switchport mode trunk

channel-group 2 mode active

!

interface FastEthernet0/2

switchport mode trunk

channel-group 2 mode active

!

interface FastEthernet0/10

switchport access vlan 10

switchport mode access

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

mac-address 0007.ecc6.3901

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

mac-address 0007.ecc6.3902

ip address 192.168.20.1 255.255.255.0

!

 

The multilayer switch has no VLAN configuration yet. The only configuration is for the etherchannel links.

 

Any help would be greatly appreciated

-Stuart

1 ACCEPTED SOLUTION

Accepted Solutions
balaji.bandi
VIP Guru

There are 2 ways here :

 

1. On the Multi Layer you need to have VLAN 10 and VLAN 20

2. Multi Layer switch - Connected to Switch 1 and Switch2 configure as Trunk

3. Enable routing  - Ip routing.

4. configure

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

 

5. Switch1 and Switch 2  - remove below config

 

no interface Vlan10

!

no interface Vlan20

 

6. Configured PC VLAN 10 192.168.10.2 with Gateway 192.168.10.1 and test and advise.

 

7. Configured PC VLAN 20 192.168.20.2 with Gateway 192.168.10.1 and test and advise.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

3 REPLIES 3
paul driver
VIP Expert

Hello

The easiest solution would be to remove the addressing of both sw1/2 and apply it to only the distribution switch enabling ip routing along and adding their presepective L2 vlans

Keep the tunking and L2 vlans on all switches as it is.

 

Note: ip routing is only required for communication between vlans it isn’t required for host to host communication within the same vlan 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
balaji.bandi
VIP Guru

There are 2 ways here :

 

1. On the Multi Layer you need to have VLAN 10 and VLAN 20

2. Multi Layer switch - Connected to Switch 1 and Switch2 configure as Trunk

3. Enable routing  - Ip routing.

4. configure

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

 

5. Switch1 and Switch 2  - remove below config

 

no interface Vlan10

!

no interface Vlan20

 

6. Configured PC VLAN 10 192.168.10.2 with Gateway 192.168.10.1 and test and advise.

 

7. Configured PC VLAN 20 192.168.20.2 with Gateway 192.168.10.1 and test and advise.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Here i am putting Intervlan routing through Multilayer switch configuration. Please go through this configuration file. Which i did couple of hour before
Switch#sh run

Building configuration...



Current configuration : 1668 bytes

!

version 12.2(37)SE1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

switchport nonegotiate

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

switchport nonegotiate

!

interface FastEthernet0/3

switchport access vlan 30

switchport mode access

switchport nonegotiate

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

mac-address 00e0.b054.9801

ip address 192.168.0.1 255.255.255.224

!

interface Vlan20

mac-address 00e0.b054.9802

ip address 192.168.0.33 255.255.255.224

!

interface Vlan30

mac-address 00e0.b054.9803

ip address 172.16.0.1 255.255.255.0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end