cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
3754
Views
5
Helpful
2
Replies
Neil Stewart
Beginner

IOS-XE Auto Qos - Warning

Hello

Having enabled "auto qos trust" on a 3850-48P, we are seeing the below messages.

*Sep 14 00:49:59.044:  Warning: Modification to policy AutoQos-4.0-Trust-Cos-Input-Policy on wired port is unrecommended, please remove and reapply if unexpected behavior is seen

*Sep 14 00:49:59.044:  Warning: Modification to policy AutoQos-4.0-Output-Policy on wired port is unrecommended, please remove and reapply if unexpected behavior is seen

*Sep

interface GigabitEthernet2/0/3

switchport access vlan 2

switchport mode access

switchport voice vlan 3

auto qos trust

spanning-tree portfast

service-policy input AutoQos-4.0-Trust-Cos-Input-Policy

service-policy output AutoQos-4.0-Output-Polic

*Sep 14 00:49:59.044:  Warning: Modification to policy AutoQos-4.0-Trust-Cos-Input-Policy on wired port is unrecommended, please remove and reapply if unexpected behavior is seen

*Sep 14 00:49:59.044:  Warning: Modification to policy AutoQos-4.0-Output-Policy on wired port is unrecommended, please remove and reapply if unexpected behavior is seen

The error message appear multiple times when autoqos was applied and also appears multiple times when a port is connected\disconnected ?

See below sample port config

interface GigabitEthernet2/0/3
switchport access vlan 2
switchport mode access
switchport voice vlan 3
auto qos trust
spanning-tree portfast
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

Any guidance or explanation would be great.

Thanks

2 REPLIES 2
Richard Primm
Cisco Employee

Hi Neil,

For the most part, these can safely be ignored.  We see this often and there are a few internal bugs to get these log messages cleaned up. They will most likely be suppressed in 3.3 which is due out in October.

A couple things to remember:

++If this message is seen after  a policy is modified through configuration, it is recommended to detach the policy and re-attach it to ensure that the QOS policy works correctly.

++If this message appears due to interface up/down or speed negotiation, it is okay to ignore it.

Hope that helps.

-Luke

Is it possible to get anyone to confirm this answer as correct? I have a pretty good understanding of QoS and there were no changes to the policy at all, just interface up/downs that triggered the warning about Modification to policy is unrecommended. Thus, I'm inclined to believe your answer because I can't think of any reason why an interface flap would have a real negative impact on marking policies. Can anyone else concur with this answer?