cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1883
Views
0
Helpful
5
Replies

IOS XR vrrp secondary address in different subnet

evivan0010
Level 1
Level 1

Hello!
I have to configure vrrp router with secondary address in different subnet.

in IOS 15 I used:

interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
vrrp 1 ip 192.168.1.10
vrrp 1 ip 192.168.100.1 secondary
!
ip route 192.168.100.0 255.255.255.252 FastEthernet1/0

and it works, but not in IOS XR 5.1

In IOS XR i use:


interface TenGigE0/0/2/0.3104
 ipv4 address 192.168.76.249 255.255.255.248
 encapsulation dot1q 3104
!
router vrrp
 interface TenGigE0/0/2/0.3104
  address-family ipv4
   vrrp 104
    address 192.168.86.17 secondary
    address 192.168.76.250
   !
  !
 !
!

show:

RP/0/RSP0/CPU0:ISOXR-CISCO#show ip route 192.168.86.17
Fri Nov 13 12:28:57.954 MSK

Routing entry for 192.168.86.16/30
  Known via "static", distance 1, metric 0 (connected)
  Installed Nov 13 12:03:36.043 for 00:25:22
  Routing Descriptor Blocks
    directly connected, via TenGigE0/0/2/0.3104
      Route metric is 0
  No advertising protos.
RP/0/RSP0/CPU0:ISOXR-CISCO#show vrrp det       
Fri Nov 13 12:29:09.744 MSK
TenGigE0/0/2/0.3104 - IPv4 vrID 104
  State is Master
    2 state changes, last state change 00:28:40
    State change history:
    Nov 13 12:00:25.810 MSK  Init     -> Backup   Delay timer expired
    Nov 13 12:00:29.425 MSK  Backup   -> Master   Master down timer expired
  Last resign sent:     Never
  Last resign received: Never
  Virtual IP address is 192.168.76.250
  Virtual MAC address is 0000.5E00.0168
  Master router is local
  Version is 2
  Advertise time 1 secs
    Master Down Timer 3.609 (3 x 1 + (156 x 1/256))
  Minimum delay 1 sec, reload delay 5 sec
  Current priority 100
    Configured priority 100, may preempt
      minimum delay 0 secs
  Note: The following configured IP addresses are not used
        as they don't belong to a network on this interface:
    Secondary Virtual IP address 192.168.86.17

Works in IOS 15 and does not in XR 5.1 :(

How i can enable it?

5 Replies 5

niko
Level 1
Level 1

Hi, One way to go would be creating different VRRP group as IOS-XR seems to be kind of a strict with this stuff.

Example:

interface GigabitEthernet0/0/0/0
ipv4 address 10.10.10.1 255.255.255.0
ipv4 address 6.6.6.2 255.255.255.0 secondary
!
router vrrp
interface GigabitEthernet0/0/0/0
address-family ipv4
vrrp 1
address 10.10.10.2
!
vrrp 2
address 6.6.6.6
!
!
!
!
end

HTH.

It is not the solution for me.

I mean that i have /30 subnet. My ISP gave me only /30 subnet and i have to configure VRRP only for one IP address. I don't have to configure it on the subinterface, because i have only /30 subnet.

I have to create vrrp router with IP 192.168.86.17 as active and in the same time IP 192.168.86.17 should not be configure on the interface.

as this:

interface TenGigE0/0/2/0.3104
 ipv4 address 192.168.76.249 255.255.255.248
 encapsulation dot1q 3104
!
router vrrp
 interface TenGigE0/0/2/0.3104
  address-family ipv4
   vrrp 104
    address 192.168.86.17 secondary
    address 192.168.76.250
!

192.168.76.248/29 -  my subnet for vrrp service messages

and 192.168.86.17 -  the vrrp active IP address

How can i do this? this config works on IOS 15, but does not work on IOS XR

Sorry if I'm no catching what you are looking to do there, but if you have to be master for that IP, set interface secondary IP same as VRRP IP, basically:

interface GigabitEthernet0/0/0/0
ipv4 address 10.10.10.1 255.255.255.0
ipv4 address 6.6.6.2 255.255.255.0 secondary
!
router vrrp
interface GigabitEthernet0/0/0/0
address-family ipv4
vrrp 1
address 10.10.10.2
!
vrrp 2
address 6.6.6.2
!
!
!
!
end

That way you will use one IP.

But how is the VRRP used in your case? Which is the secondary router in the VRRP group - ISP? Given your hint it is /30 subnet, I don't really see the point as there will be no more devices in that subnet, but sorry again if I'm not getting it. :)

OK. Look at the attached picture. I have to implement this scheme.

ISP - router of my ISP

R1 and R2 - my routers in one VRRP group.

ISP gives me 1 ip address in /30 subnet and a lot of networks (example as 172.16.0.0/12) by statically route . It is seen on the scheme.

Hello Evivan,

I have setup similar to yours, have reached a solution here with IOS XR ?

Thanks,

Ahmed

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card