cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1424
Views
0
Helpful
4
Replies

Layer 3 to Layer 2 Cross Vlan

DocSkyhawk
Level 1
Level 1

I am having an issue trying to get IP routing working using a layer 3 switch as a core and layer 2 switches in IDFs.  The Core(layer 3) has several VLANs on it each with the IP address on the vlan interface.  There are several hosts on each of the vlans directly to the core and IP routing is working great.  I can ping each host across the vlans/subnets.  Example:  Vlan 10: IP 10.10.10.200 -> gateway to 10.10.10.1 pings vlan host 10.10.20.200 w/10.10.20.1 gateway and vice versa.  This switch seems fine.

 

Port g0/1 is setup as a trunk with native vlan 100 to switch #2 (layer 2) with all of the same vlans.  The port on switch 2 is set to trunk with native vlan 100 as well. Similar devices are on that switch on the same subnets matching the vlans.  Any host on switch 2 can ping any host or interface on switch 1(layer 3) but can not ping other vlans on its own switch.(yes the hosts have their DG set to the vlan interface on the layer 3). 

 

BTW this is on Packet Tracer right now as tests.  I ran it in simulation and when I ping from the layer 2 switch side hosts, the packet makes to the the switch->L3 switch->then the other host and responds no matter what vlan/host.  When I ping from the layer 3 side, the packet gets to the the gateway -> gets to the layer 2 switch -> to the host, but fails.  If I change that hosts subnet to 255.255.0.0, it works so it has something to do with it not wanting to talk to other subnets on the layer 2 side.  It will talk to other subnets on layer 3.  Any help would be great.

4 Replies 4

Hello

just for clarification make sure your L3 core has ip routing enabled and disabled on all l2 switches 

 

All L2 vlans  are populated in the access switches cap database 

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

DocSkyhawk
Level 1
Level 1


Current configuration : 2161 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Office1-CR-01
!
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet1/0/1
switchport trunk native vlan 60
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
switchport access vlan 10
!
interface GigabitEthernet1/0/6
switchport access vlan 20
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
switchport access vlan 5
switchport trunk native vlan 60
!
interface GigabitEthernet1/1/1
switchport access vlan 5
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan5
mac-address 00e0.8f35.5c02
ip address 10.10.5.1 255.255.255.0
!
interface Vlan10
mac-address 00e0.8f35.5c03
ip address 10.10.10.1 255.255.255.0
!
interface Vlan20
mac-address 00e0.8f35.5c04
ip address 10.10.20.1 255.255.255.0
!
interface Vlan50
mac-address 00e0.8f35.5c05
ip address 10.10.50.1 255.255.255.0
!
interface Vlan60
mac-address 00e0.8f35.5c06
ip address 10.10.60.1 255.255.255.0
!
interface Vlan100
mac-address 00e0.8f35.5c07
ip address 10.10.100.1 255.255.255.0
!
interface Vlan500
mac-address 00e0.8f35.5c08
no ip address
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
!
end

DocSkyhawk
Level 1
Level 1

Layer 2.  I put ip addresses on some of the vlans as tests but it didn't change anything.

 

Building configuration...

 

Current configuration : 1753 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname DC-RACK-1

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport access vlan 10

!

interface FastEthernet0/2

switchport access vlan 10

!

interface FastEthernet0/3

switchport access vlan 20

!

interface FastEthernet0/4

switchport access vlan 50

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

switchport trunk native vlan 60

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan5

mac-address 0009.7c42.3101

no ip address

!

interface Vlan10

mac-address 0009.7c42.3102

ip address 10.10.10.3 255.255.255.0

!

interface Vlan20

mac-address 0009.7c42.3103

ip address 10.10.20.5 255.255.255.0

!

interface Vlan50

mac-address 0009.7c42.3104

no ip address

!

interface Vlan60

mac-address 0009.7c42.3105

no ip address

!

interface Vlan100

mac-address 0009.7c42.3106

ip address 10.10.100.2 255.255.255.0

!

interface Vlan500

mac-address 0009.7c42.3107

no ip address

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

!

!

end

Hello

whatever switch is your L3 switch - 

 

enable ip routing

keep the L3 svi

make sure l2 vlans are populated in vty database 

trunk to all access layer layer switches allowing all vlans

 

On all access switch remove the l3 svi interfaces 

 

disable up routing 

trunk to core seitch allowing all vlans

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul