cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
530
Views
0
Helpful
1
Replies

Link redundancy on Cisco 1841

sidcracker
Level 1
Level 1

Hello,

I am trying to achieve redundancy on the cisco 1841 router. I have two links one for a private circuit and the other towards the firewall. How can i best acheive redundancy. SO if one link goes down then traffic can flow through the other link

I have made the foll config

interface Tunnel0
ip address 192.168.28.1 255.255.255.252
keepalive 3 3
tunnel source Serial0/0/0
tunnel destination 20.20.20.20

interface FastEthernet0/0
ip address 192.168.15.254 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/1
ip address 192.168.16.2 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.20.20.16 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.16.1
ip route 20.20.20.18 255.255.255.252 20.20.20.15
!
ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login local
line vty 5 15
login local
!
scheduler allocate 20000 1000
end

1 Reply 1

Hi Sid,

You can achieve this by ip sla monitor commands and track the link. if the primary link goes down the second link can come up.

http://198.133.219.25/en/US/docs/ios/12_4/ip_sla/configuration/guide/hsicmp.html

ip sla monitor 6

 type echo protocol ipIcmpEcho

 frequency 300
timeout 2000

!

ip sla monitor schedule 6 life forever start-time now

ip router 0.0.0.0 0.0.0.0 1 track 6
ip route 0.0.0.0 0.0.0.0 200