05-17-2011 11:05 AM - edited 03-06-2019 05:06 PM
Hi guys!
I have a router (2811) configured to NAT addresses between my internal network and the internet.
If I connect my laptop straight to the internal network port (FE0/0) I am unable to ping to the internet, but if i try to ping from the router it's sucessfull.
My friend tried to debug this and the following error was showing a lot of times - NAT-symdb: DB is either not enabled - I don't understand why.
I alradey tried to apply a static IP address in the Internet port (FE0/1) but it stills the same
Here you have the configuration in the router:
interface FastEthernet0/0
ip address 10.128.1.254 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp client-id FastEthernet0/1
ip nat outside
ip nat enable
ip virtual-reassembly
duplex auto
speed auto
!
no ip forward-protocol nd
!
!
no ip http server
ip nat inside source list 100 interface Fast
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
access-list 100 permit ip any any log-input
05-17-2011 11:18 AM
Paulo
Can you do the following -
1) under each interface remove the "ip nat enable" command but leave the "ip nat [inside/outside]" config line
2) can you confirm that you have the full statement in your config -
ip nat inside source list 100 interface fa0/1 overload
3) can you then try to connect from an internal host and post -
i) the output of "sh ip nat translations"
ii) confirm the IP address of the internal device you pinged from
Jon
05-18-2011 02:16 AM
Hi John!
1) I did what u said to me and the config now is:
interface FastEthernet0/0
ip address 10.128.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp client-id FastEthernet0/1
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
no ip forward-protocol nd
!
!
no ip http server
2) ip nat inside source list 100 interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
access-list 100 permit ip any any log-input
05-18-2011 02:39 AM
Ok, now all seems Ok and you have Internet access for clients behind Fa0/0, right?
Also I suggest you modify ACL 100:
access-list 100 permit ip 10.128.1.0 0.0.0.255 any
This way you control for who you DO NAT.
05-18-2011 02:57 AM
Thank you guys, it's working now!
I had to reload the router 3 times before it picked the internet connection i don't understand why but it worked.
01-30-2019 11:27 PM
Hello,
yesterday I got the same issue... please take a look here: https://www.cisco.com/en/US/docs/ios-xml/ios/ipaddr_nat/configuration/15-0s/iadnat-monmain.html
"NAT does not support ACL with the log option."
Removing the "log" option at the end of the ACL it will work fine.
Regards,
Andrea
11-06-2019 07:18 AM
Removing the log option worked for me. Thank you Andrea.
07-22-2020 04:11 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide