cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1539
Views
16
Helpful
9
Replies
Beginner

NAT: translation failed

Hi

I am trying to configure NAT on a 3900 router but I am getting errors.

config & the errors are listed below

Could anyone please help me identify the problem ?

kind regards

Message was edited by: Keith Newbould

Int Gi0/0

Ip address 10.245.10.186 255.255.255.252

Ip nat outside

!

Int Gi0/2

Ip address 192.168.1.1 255.255.255.0

Ip nat inside

!

Access-list 151 permit tcp host 192.168.181.41 host 10.49.1.51 eq 25

Access-list 151 permit tcp host 192.168.182.41 host 10.49.1.51 eq 25

!

Ip nat pool 151 10.49.5.51 10.49.5.51 netmask 255.255.255.252 overload

!

Ip nat inside source list 151 pool 151

!

Ip route 192.168.181.0 255.255.255.0 192.168.1.254

!

Router#

The error I get is as follows:

*Jul 21 10:50:43.964: NAT: failed to allocate address for 192.168.181.41, list/map 151

*Jul 21 10:50:43.964: mapping pointer available mapping:0

*Jul 21 10:50:43.964: NAT*: Can't create new inside entry - forced_punt_flags: 0

*Jul 21 10:50:43.964: NAT: failed to allocate address for 192.168.181.41, list/map 151

*Jul 21 10:50:43.964: mapping pointer available mapping:0

*Jul 21 10:50:43.964: NAT: translation failed (A), dropping packet s=192.168.181.41 d=10.49.1.51

1 ACCEPTED SOLUTION

Accepted Solutions

NAT: translation failed

YES....

Please rate the helpfull posts.
Regards,
Naidu.

View solution in original post

9 REPLIES 9

NAT: translation failed

Hi,

Clear the nat translations and stats, it should fix after you did.

clear ip nat translation
clear ip nat statistics


Please rate the helpfull posts.
Regards,
Naidu.

NAT: translation failed

Hi,

If the above not solved your problem you could change your config as like below...


Router(config) ip access-list extended NAT
10 permit tcp host 192.168.181.41 host 10.49.1.51 eq smtp


route-map NAT permit 10
match ip address NAT


ip nat pool NAT 10.49.5.51 10.49.5.51 netmask 255.255.255.252

ip nat inside source route-map NAT pool NAT


Please rate the helpfull posts.
Regards,
Naidu.

Beginner

NAT: translation failed

Hi Naidu

tried route-map butstill getting the same error

regards

Keith

Beginner

NAT: translation failed

thanks for the assistance Naidu but it did not fix the problem - I couldn't see anything already mapped either

regards

Keith

Hall of Fame Guru

NAT: translation failed

Keith

Just be aware if you do clear the nat translations as Naidu suggests this will break all existing connections that are using NAT on the router so if there are a lot best to do it out of hours.

Jon

Beginner

NAT: translation failed

cheers Jon - only one translation at the moment so it's fine -

regards

Keith

NAT: translation failed

Hi Keith,

OK, do like below...hope this will deffinetely helps you.


ip nat pool NAT 10.49.5.51 10.49.5.51 netmask 255.255.255.252

ip nat inside source route-map NAT pool NAT overload

ip nat inside source static tcp 192.168.181.41 25 public_ip 25 extendable


Please rate the helpfull posts.
Regards,
Naidu.

NAT: translation failed

YES....

Please rate the helpfull posts.
Regards,
Naidu.

View solution in original post

Beginner

Re: NAT: translation failed

Hi Naidu

tried this option but it failed also.  I have posted a more detailed peace of the NAT configuration - hopefully that explains it better

regards

Keith

CreatePlease to create content
Content for Community-Ad