07-15-2013 01:37 AM - edited 03-07-2019 02:24 PM
Hi!
Can you help me properly configure my 1900 Cisco Router with static ip address to direct all incoming traff to my Wamp server to view home.html - with ip address 192.168.1.250? But at the same time allow other users to access internet from the inside. Here's my running config.
Building configuration...
Current configuration : 4267 bytes
!
! Last configuration change at 01:03:54 UTC Thu Apr 25 2013
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MJ Co
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$EFuY$mwbG0eyiV7KrtoIylAoAq.
enable password 7 0305550C0303284F1F5F41
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool inside
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 202.80.97.41 210.40.2.61
domain-name bayan.com.ph
!
!
no ip domain lookup
ip domain name yourdomain.com
ip name-server 203.172.11.25
ip name-server 203.172.11.21
ip name-server 202.163.239.2
multilink bundle-name authenticated
!
!
crypto pki trustpoint TP-self-signed-636006880
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-636006880
revocation-check none
rsakeypair TP-self-signed-636006880
!
!
crypto pki certificate chain TP-self-signed-636006880
certificate self-signed 01
3082024A 308201B3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 36333630 30363838 30301E17 0D313131 32303530 37313634
365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3633 36303036
38383030 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
F9781012 6F901585 BC0B1853 0ED7314E DDED4945 5C50B9FD 0B5597C5 09FEDD29
D026A3F1 EEEA8AC6 AD3D8023 C35F318D C177B708 3BD0DB77 5CF8815C 4236A01A
2D4ACC13 655E4A2A 188359E1 61BD927E 2F788BFB E2F73DBF 7AB6A0D4 6724942C
3D89D500 B06C2751 3D311B5B 98E5B889 5254C43A BF701721 FF3653CB 8D1D4E9F
02030100 01A37430 72300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
11041830 1682144A 50414354 2E796F75 72646F6D 61696E2E 636F6D30 1F060355
1D230418 30168014 444EC2B4 800EC353 DE9F88AA 48EC0B4F EE93710F 301D0603
551D0E04 16041444 4EC2B480 0EC353DE 9F88AA48 EC0B4FEE 93710F30 0D06092A
864886F7 0D010104 05000381 81008EB1 CA4FF714 F0830EB7 A4682AD7 1B68D37E
15BE12BD 91F5CBE4 0755D352 CFAF67FD 83E5D464 70C250E4 EC3ED1E0 9E66513C
5461B57D 7AECC247 31CBA81E 8AA38D17 353CB256 FDE6E0A6 3470AC62 9E1740A0
3BB75C6E 91505595 F23762C7 BDF7AEDE 80DE73C4 42E8266B 9F965F08 F823E16A
18D95385 B47970A0 9E0F95F2 906E
quit
license udi pid CISCO1941/K9 sn FGL1543200Y
!
!
username admin privilege 15 secret 5 $1$AdVe$81.48GWp.DjDBTBg7e0RC/
!
!
!
!
!
!
interface GigabitEthernet0/0
description CONNECTION_TO_BAYAN
ip address 202.80.101.14 255.255.255.252
ip load-sharing per-packet
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/1
description CONNECTION_TO_LAN
ip address 192.168.1.1 255.255.255.0 secondary
ip address 202.80.102.98 255.255.255.224
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1/0
description Connect to ISP-PLDT
no ip address
ip load-sharing per-packet
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list LAN-IP interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 202.80.101.13
ip route 0.0.0.0 0.0.0.0 122.50.15.41 2
!
ip access-list standard LAN-IP
permit 192.168.1.0 0.0.0.255
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
password 7 02072A5C0E0A06221D1958
logging synchronous
login
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 0 0
privilege level 15
password 7 0305750C0303284F1F5F41
logging synchronous
login
transport input telnet ssh
line vty 5 14
access-class 23 in
exec-timeout 0 0
privilege level 15
password 7 14163C0C09082328757E6A
logging synchronous
login
transport input telnet ssh
line vty 15
access-class 23 in
privilege level 15
password 7 094D600E1C091E115A5B54
login
transport input telnet ssh
!
scheduler allocate 20000 1000
end
I just want to setup my webserver thru my 1900 cisco router but maintain internet access for all pcs in my network.
Thanks in advance! Appreciate it.
Regards,
Martin
Solved! Go to Solution.
07-15-2013 07:46 AM
Hi,
you need to configure port forwarding or static PAT.
ip nat inside source static tcp 192.168.1.250 80 interface g0/0 80
Now from Outside you'll be able to get to the Wamp server IP by using the external IP
If you want to use the name instead of IP then you'll have to use DNS.
Regards
Alain
Don't forget to rate helpful posts.
07-15-2013 07:46 AM
Hi,
you need to configure port forwarding or static PAT.
ip nat inside source static tcp 192.168.1.250 80 interface g0/0 80
Now from Outside you'll be able to get to the Wamp server IP by using the external IP
If you want to use the name instead of IP then you'll have to use DNS.
Regards
Alain
Don't forget to rate helpful posts.
07-25-2013 01:31 AM
Hi Alain!
Thanks for your prompt response on this issue. Appreciate your help!
Cheers!
Regards,
Martin
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide