cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
612
Views
0
Helpful
3
Replies

Nexus 5500 routing

Dave Kozlowski
Level 1
Level 1

I need some help

How to you setup ip routing on a Nexus 5500

I want to do vlan routing between an Nexus 5500 and Catalyst 3750. Nothing clever just have the 2 switches talk and vlans route between the two.

Thanks

Dave

3 Replies 3

Steve Fuller
Level 9
Level 9

Hi Dave,

First thing you'll need to confirm is that you have a Layer-3 module in the Nexus switch, you have the license for it installed and it's enabled. You should be able to see this with the show module command and look for something along the lines of N55-D160-L3.

Then which routing protocol are you going to be running? In NX-OS these are not enabled by default so you have to enable the protocol you want with the feature command e.g., feature eigrp, feature ospf etc.

When you've enabled the routing protocol, then you need to enable the interface to the Catalyst switch as a routed interface. The difference between NX-OS and the Catalyst 3750 IOS is that you run the ip router command on the interface to enable the routing protocol for that interface. For example:

!

interface ethernet 1/1

  description Link to C3750

  no switchport

  ip address 192.168.1.1/30

  ip router eigrp 1

!

The routing protocol itself is pretty much the same as standard Cisco IOS devices, for example:

!

router eigrp 1

  router-id 192.68.2.133

  default-metric 10000 20000 255 1 1500

  redistribute static route-map STATIC_TO_EIGRP

!

Hope that helps.

Regards

You can also run certian routing protocol commands under the interface in IOS as well. Similar to the Nexus.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Bilal Nawaz
VIP Alumni
VIP Alumni

Hello, most of it is the same as any other IOS router/switch.

An example of a simple point to point OSPF neighborship with the two, on a particular vlan (a routed vlan) and the physical interface will itself be a trunk, lets say we have a 3750 on gi1/0/1 connected to Nexus5k e1/1

3750:

conf t

!

vlan 100

!

interface vlan 100

description ***Routed VLAN to Nexus5k***

ip address 100.0.0.2 255.255.255.252

ip ospf 1 area 0

ip ospf network point-to-point

!

interface gi1/0/1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

Nexus5K

conf t

!

feature ospf

feature interface-vlan

!

vlan 100

!

interface vlan 100

description ***Routed to 3750***

ip address 100.0.0.1/30

ip ospf 1 area 0.0.0.0

ip ospf network point-to-point

!

int e1/1

switchport

switchport mode trunk

This way we have a trunk, and a vlan where we will have a point-to-point adjacency. This does require you to have the layer 3 license on the nexus5k and the correct feature set on the 3750. You can then redistribute your vlans or advertise them however way you need to...

Hope this helps

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.