cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
317
Views
5
Helpful
6
Replies
Highlighted
Enthusiast

NX7K L3 vPC

Hello,

 

We have a pair of NX7Ks and they are configured in a vPC. We have a requirement to connect the pair of the vPC peers(NX7K_01 and NX7K_02) to a Router using a L3 Port-Channel and use sub-interfaces on this port-channel.

The doc below under the "Layer 3 over vPC for F2E, F3 and M3 Modules" section discuss the use L3 over vPC.

Our NX7Ks are on NX-OS 8.4(3) and using N77-M3448XP-23L modules.

 

My questions are

   -  Does the NX7K support L3 vPC?

   -  If so, does the L3 vPC support sub-interface configuration?  

 

 

 

Example of configuration NOT tested yet:

 

NX7K_01:NX7K_02:
  
interface e1/1 interface e1/1
no shut  no shut
vpc 10  vpc 10
   !   !
interface e1/1.200   interface e1/1.200
ip address 192.0.2.2/8   ip address 192.0.2.3/8
encapsulation dot1Q 200   encapsulation dot1Q 200
hsrp version 2   hsrp version 2
hsrp 200   hsrp 200
authentication md5 key-chain hsrp-keys   authentication md5 key-chain hsrp-keys
preempt   ip 192.0.2.1
priority 110  ! 
 ip 192.0.2.1 
  !   interface e1/1.201
interface e1/1.201  ip address 172.16.0.3/16
ip address 172.16.0.2/16  encapsulation dot1Q 201
encapsulation dot1Q 201  hsrp version 2
hsrp version 2  hsrp 201
hsrp 201  authentication md5 key-chain hsrp-keys
authentication md5 key-chain hsrp-keys  ip 172.16.0.1
preempt  !
priority 110 
ip 172.16.0.1 
  

 

 

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus7000/sw/interfaces/config/cisco_nexus7000_interfaces_config_guide_8x/config-vpcs.html#concept_F862A25175DE4C738065F0EDA6F5D8C0

 

Thanks in

6 REPLIES 6
Highlighted
VIP Advisor

Highlighted
Hall of Fame Expert

Hi,

L3 VPC should be supported but if you want to use a subinterface with a vpc and a Portchannel, the config needs to go under the Portchannel interface and not the physical interface.

Guidelines and Limitations for Layer 3 Interfaces

Layer 3 interfaces have the following configuration guidelines and limitations:

  • If you change a Layer 3 interface to a Layer 2 interface, Cisco NX-OS shuts down the interface, reenables the interface, and removes all configuration specific to Layer 3.

  • If you change a Layer 2 interface to a Layer 3 interface, Cisco NX-OS shuts down the interface, reenables the interface, and deletes all configuration specific to Layer 2.

  • Configuring a subinterface on a physical interface that is configured to be a member of a port-channel is not supported. One must configure the subinterface under the port-channel interface itself.

  •  
Highlighted

Regarding the third point. I'm curious, can the same be accomplished on a VSS (a pair of C6509s)? Do you happen to have a document to explain the steps to do that? 

 

Thanks in advance,

~zK

Highlighted

Highlighted

Correct, I see this:

sometimes it is software-dependent. 

• Subinterfaces cannot be created on Layer 3 EtherChannels

HTH 

Highlighted

I found this old post(I posted it and totally forgot that I did)... You can create sub-interfaces on a L3 Port-channel/Etherchannel on the NX7Ks. I have never configured a vPC on a L3 Port-channel with sub-interfaces. This is what I want to figure out.


https://community.cisco.com/t5/switching/l3-port-channel-sub-interfaces/td-p/3025548


Apparently, you can also create L3 Port-channel/Etherchannel with sub-interfaces on VSS. The configuration would be the same:

 

interface Port-channel800
!
interface Port-channel800.90
encapsulation dot1Q 90
ip address 90.90.90.1 255.255.255.0
!
interface Ten1/0/30
no ip address
negotiation auto
channel-group 90 active
!
interface Ten2/0/30
no ip address
negotiation auto
channel-group 90 active

Content for Community-Ad