cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
675
Views
0
Helpful
5
Replies

PC Not getting DHCP from DHCP server configured in router

nischal31
Level 1
Level 1

I am having a problem getting DHCP on my PC LAN

Router (DHCP Server) (ISR4331)(192.168.70.1)-- Switch (3750G) (IP helper address 192.168.70.1 on Vlan 1) - PC (192.168.70.x)

The port coming from router (DHCP server) is connected to G1/0/1 Catalyst 3750G switch.

The exact same configuration works on packet tracer though but does not work on real device.

I have also included wireshark packet capture of DHCP message.packettracerPC.pngpackettracerl3switch.pngPackettracer router.pngWireshark.png

Can anyone help me with this.

SWITCH CONFIGURATION

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ps
system mtu routing 1500
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
ip address dhcp
ip helper-address 192.168.70.1
!
ip classless
ip http server
ip http secure-server
!
!
!
line con 0
line vty 5 15
!
end

 

Router configuration (DHCP Server) =192.168.70.1


ip dhcp pool LAN_POOL
network 192.168.70.0 255.255.255.0
default-router 192.168.70.1 255.255.255.0
dns-server 8.8.8.8
!
!
!
!

interface GigabitEthernet0/0/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/1
ip address 192.168.70.1 255.255.255.0
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
interface Vlan1
no ip address
shutdown

I'm just curious why exact same configuration worked on packet tracer but not on real device. Please help me on this

 

Thanks

5 Replies 5

Hello,

which IP address is the Vlan 1 interface on the switch getting ? Most likely an IP address from the 192.168.70.0/24  range as well, that is why your DHCP does not work. Shut down the Vlan 1 interface on the switch and try again. Or give the Vlan 1 interface on the switch (which is meant for management only anyway) an IP address from a different sunet (and remove the IP helper-address)...

Hi,

Shutting down the vlan 1 interface does not have any effect.  But, isnt the IP helper-address supposed to be there to give rest of the ports (2-24) the IP adress coming from the router ?The same configurations works in packet tracer but not on real device pretty strange. The server connected to the same config is getting DHCP though. If I put static IP on my PC it can communicate to the LAN within that segment though.

@nischal31 , I would advise you to remove interface vlan from the router, issue the command, "no interface vlan 1".

Try it. If the issue is solved, mark the comments as solution and like this.

Gopinath_Pigili
Spotlight
Spotlight

Hello  nischl31,

As you mentioned packet tracer it's working. I suggest, following setps to be performed in windows client pc.

Open Task Manager --> go to Services Tab --> Restart Dhcp Client Serive

Gopinath_Pigili_1-1704985075477.png

 

or Open Command Prompt with Administrative rights (Run as administrator) and execute following commands:

net stop dhcp
net start dhcp

Best regards
******* If This Helps, Please Rate *******

 

 

mohamedlamine
Level 1
Level 1

i think in this case you must restart dhcp service from task manager 

 

Review Cisco Networking for a $25 gift card