cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2506
Views
0
Helpful
2
Replies

Port choosing VLAN - unable to get IP

Kan Aky
Beginner
Beginner

A port is working for VLAN 1, but when i set it for VLAN 2, it couldn't get ip from that VLAN. Sometimes it gets IP, but unable to connect Internet. (It says "DNS problem". Then i release the IP, it will get IP by 169.XXX.XXX

By the way, some ports in the same switch, are working for both VLAN, some of them couldn't.

What's the wrong thing?

1 Accepted Solution

Accepted Solutions

Julio E. Moisa
VIP Mentor VIP Mentor
VIP Mentor

Hi

As suggestion the vlan 1 should not be used and it should be shutdown for security purposes, I would like to know how are you providing DHCP to the vlan 2. 

How these vlans are different segments we should have the following configuration:

interface vlan 1
ip address 1.1.1.1 255.255.255.0
ip helper-address <dhcp server IP>
no shutdown

interface vlan 2
ip address 2.2.2.1 255.255.255.0
ip helper-address <dhcp server IP>
no shutdown

End user interface
interface fa1/1/1
switchport host  (optional, it will provide config for access mode)
switchport access vlan 2
swtichport mode access
no shutdown

Are you using a DHCP server standalone or DHCP configured on a router? Could you please share a topology and your configuration?

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

2 Replies 2

Julio E. Moisa
VIP Mentor VIP Mentor
VIP Mentor

Hi

As suggestion the vlan 1 should not be used and it should be shutdown for security purposes, I would like to know how are you providing DHCP to the vlan 2. 

How these vlans are different segments we should have the following configuration:

interface vlan 1
ip address 1.1.1.1 255.255.255.0
ip helper-address <dhcp server IP>
no shutdown

interface vlan 2
ip address 2.2.2.1 255.255.255.0
ip helper-address <dhcp server IP>
no shutdown

End user interface
interface fa1/1/1
switchport host  (optional, it will provide config for access mode)
switchport access vlan 2
swtichport mode access
no shutdown

Are you using a DHCP server standalone or DHCP configured on a router? Could you please share a topology and your configuration?

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Kan Aky
Beginner
Beginner

It's done, thank you. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers